1

I am trying to use jupyter notebook from a remote and I know I am able to access it using port tunneling when I ssh:

ssh -L 8000:localhost:8888 me@0.0.0.0

as when I launch a jupyter notebook on the server and open a browser and go to http://localhost:8000/ I reach jupyter notebook. But it queues me for a password that I never set up.

If I try to set up a password using:

jupyter notebook --generate-config

jupyter notebook password

and setting a password. This password does not get stored in my jupyter_notebook_config.json file and I get invalid credentials using this password or the hash stored in the json file.

I don't want to be prompted for a password at all! But at the very least I would want to be able to login with the password I specify.

I have worked through all the suggestions I could find so far to no avail.

1

I discovered that if you port tunnel with the same port as local (for some reason) and then tell jupyter to use that port, I am able to access the notebook server without a password. The password indicated that I was doing something wrong.

This is what worked:

ssh -L 8000:localhost:8000 me@0.0.0.0
jupyter notebook --port=8000

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.