0

To make my Windows 10 system act more like the macOS behavior that I'm accustomed to, I remapped my keyboard following the instructions of Orwellophile when they answered the question of how to Switch Ctrl and Alt with AutoHotKey without messing up the Alt-Tab switcher? here on Super User.

It works OK – most of the time – but I'm finding it also screws up a bunch of other (Adobe) shortcuts that I use all the time. So I think I should go back to the default settings and remap my brain instead.

So my question is: how do I undo the registry edit? I didn't make a backup prior to the change, and even if I did I've been using the computer for a couple of weeks now.

5
  • The answer that (I guess) you used includes instructions on how to undo the edit. Have you tried that?  Do you have some recollection that the registry value had something else in it before you edited it? – Scott Feb 7 '19 at 5:45
  • hi scott I actually followed the advice of @Orwellophile (superuser.com/a/1096541/995157), which sadly doesn't have instructions for how to go back. I think i just pasted the code into a notepad file, saved it as a .reg and then merged it into the registry by opening the file. i'm not sure which value or values have been changed. – remote_is_remote Feb 7 '19 at 16:52
  • Well then, I don’t understand why you’re calling it a registry edit, when Orwellophile’s answer is for AutoHotkey and does not involve editing the registry. It would be clearer if you actually said what you did, rather than just linking to another Q&A. – Scott Feb 7 '19 at 17:13
  • Sorry to irritate you there Scott. I've edited my question to make it clearer – remote_is_remote Feb 9 '19 at 6:11
  • fyi I resolved my registry issues this time around by simply formatting my system drive and reinstalling windows. This was a fairly extreme move but all my data is on separate drives so all I lost was the time it took to reinstall additional software and fonts etc. there could well be other solutions (maybe if I had saved a restore point?), if anyone has any I'd love to hear them. I guess this could be the answer but I'm not sure its a good one so I'm leaving it as a comment. cheers – remote_is_remote Feb 9 '19 at 6:22
0

Download Keytweak (available at https://keytweak.en.softonic.com/ and many other popular download sites), run it and press the Restore All Defaults button.

4
  • thank you jimtut for your suggestion. there was some confusion relating to my question (i think @scott misunderstood what i had done, and editied my question accordingly). if you or anyone else can confirm that Keytweak can still fix my problem then I'll go do this, i just don't want to further complicate my issue by adding more variables into the mix. interested to hear your thoughts. cheers! – remote_is_remote Feb 7 '19 at 17:06
  • I can't say for SURE that this will solve your problem. But, I use KeyTweak every single day to switch my PC between my PC keyboard at work ("Restore all Defaults") and my Mac keyboard at home, which is controlled thru the Scancode map in the registry. I believe that "restore all defaults" should remove whatever you did w/ AutoHotKey, but it's up to you if you want to try it! – jimtut Feb 7 '19 at 17:19
  • sorry to say keytweak appears to only work on vista and windows 2000. I am on windows 10 so I don't think its going to work for me :( – remote_is_remote Feb 9 '19 at 6:44
  • You must be basing that on what the application lists as compatible operating systems. But the application was released back when those were the “current “operating systems, and it’s never been updated.. I use it every single day on Windows 10, as I have in all of the Windows operating systems for the past 10 years or so, as I move between my work office with a PC keyboard snd my home office with a Mac keyboard. – jimtut Feb 9 '19 at 15:23
0

Another approach suggests...

If you do not want to use third-party applications to reverse the SharpKeys modifications, you can cut out the middleman and edit the Registry directly.

Open the Registry Editor by navigating to C:\Windows\regedit.exe in Windows Explorer. Once it is open, navigate here:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout If there are entries named Scancode Map or Value Scancode Map, delete them. Those entries are what causes Windows to remap incoming key presses from the keyboard.

Once you are done deleting them, restart your computer. Key mappings will be reset to their default settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.