4

I am using Debian Stretch and and Firefox 60.5.0esr (64-bit). Widevine and OpenH264 are installed in Add-ons and I toggled 'Play DRM-controlled content' in Preferences. However I am still unable to use Netflix on my browser. The alert 'Firefox is installing components needed to play the audio or video on this page. Please try again later.' keeps popping up on top of the screen.

2

I had the same problem. Followed the link @eftshift0 suggested in a comment and it worked for me.

This is the part that was most helpful.

#check first what your profile is called and manually save it as
$firefox_profile ls -ld ~/.mozilla/firefox/*.default
mkdir test
cd test
wget https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1196.0-linux-x64.zip
unzip 4.10.1196.0-linux-x64.zip
rm -rf "${firefox_profile}"/gmp-widevinecdm/*
mkdir "${firefox_profile}"/gmp-widevinecdm/1.4.8.1008/
cp libwidevinecdm.so LICENSE.txt manifest.json "${firefox_profile}"/gmp-widevinecdm/1.4.8.1008/

What I actually did was downloading the zip file with my browser. https://redirector.gvt1.com/edgedl/widevine-cdm/4.10.1196.0-linux-x64.zip

Find the folder where the outdated version of widevine is located. (Ctrl+H) Clicking... Home > .mozilla > firefox > the_folder_that_ends_with.default > gmp-widevinecdm > 1.4.8.1008 (only option for me at this point)

Unpack and overwrite the files with the archive manager to that folder, for me it was exactly the same filenames, different sizes. Replace all.

(Ctrl+H again :P)

I don't remember, but maybe you need to log out of of the profile and back in for it to work.

  • Yeah! It works! I've spent a week looking for this! – AndrewQ Feb 10 at 22:30
  • I just changed the line pref("app.update.channel", "default"); to pref("app.update.channel", "esr"); in channel-prefs.js in /usr/lib/firefox-esr/defaults/pref – Alberto Feb 12 at 12:34
-1

I experienced the same issue, It happened after updating my system.

you can downgrade to 60.03esr-1~deb9u1. you can use aptitude to do so.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.