0

Totally stumped on this. Copied some mp4 files off my phone, that I need to show a correct date for. Checked the file properties and found an empty "media created" date field. The date should've read 2019/01/22 7:49 pm.

Empty media created field

Tried to use exiftool to fix the issue with the command:

"-CreateDate=2019:01:22 19:49:14-05:00" 20190122_194914.mp4

Then my machine spat 2019/01/22 2:49 pm. in my face instead.

5 hours wrong

I even used the modify all dates command

"-AllDates=2019:01:22 19:49:14-05:00" 20190122_194914.mp4

Same 5 hours behind result. Running the file on exiftool shows the correct dates. I know my system time is correct.

exiftool results

I'm running windows 10. My system time and timezone setting are correct. I haven't had this problem with the photos I copied over. The "Date Taken" value was retained, and changing things through exiftool still gives the correct time in the properties. Any suggestions on how to fix this with .mp4 videos or am I missing something with exiftool?

  • 1
    How did you copy that file from phone? cable or wireless? MTP? – Biswapriyo Feb 9 '19 at 17:07
  • create a mp4 file on your box and take that to your phone. Does that show this 5 hour difference oh phone? – VSRawat Feb 9 '19 at 17:57
  • If you are sure that pc/ lappy time is correct, could be that phone time/ zone is not correctly set. – VSRawat Feb 9 '19 at 17:58
  • @Biswapriyo Copied it via a usb cable with file transfer using MTP. – Cyrss Feb 9 '19 at 18:29
0

According to the standard, the CreateDate entry is supposed to be stored in UTC time. The trouble is that because many cameras do not store this value properly, exiftool doesn't correct the time shift when writing it to remain compatible. You have two options with exiftool. You can either manually adjust for the time zone difference e.g. "-CreateDate=2019:01:23 00:49:14" or you can tell exiftool to adjust for the timezone with the -api QuickTimeUTC, e.g. -api QuickTimeUTC "-CreateDate=2019:01:22 19:49:14-05:00"

|improve this answer|||||
  • 1
    Tried it and it works perfectly now. Thanks you. – Cyrss Feb 9 '19 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.