2
REGEDIT

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
"Desktop"="E:\\Desktop"

I'm trying to add/change this value, but its not working.. I get no errors while running the file but no changes in the registry?

4
  • The syntax of your regfile seems from an old windows version. What you will want to do is go into the registry, export the string that currently is in there to a new .reg file then edit that file and keep all the double slashes and stuff in tact and just carefully edit it to your needs.
    – LPChip
    Feb 9, 2019 at 20:17
  • I have done that.. but then the value is represented as hex
    – clarkk
    Feb 9, 2019 at 20:19
  • have also tried double backslash.. doesn't work
    – clarkk
    Feb 9, 2019 at 20:19
  • 1
    Then you need to enter it as hex. Also, you can first edit the value in RegEdit, and then export the correct key.
    – LPChip
    Feb 9, 2019 at 20:51

1 Answer 1

2

This works on my machine (Windows 10). Made this one like @LPChip described in his comment

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders]
"Desktop"=hex(2):45,00,3a,00,5c,00,44,00,65,00,73,00,6b,00,74,00,6f,00,70,00,00,00
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.