3

That's the problem I'm having while running gdb in cmd under Windows 10. This isn't a question about gdb usage. The cursor's footprint (when visible) is stamped on each line that's created within gdb in cmd. Like when pressing enter to continue stepping through code... if the cursor is visible during that key press, its footprint is visible on the most recent line that is created.

screenshot of cursor footprints within gdb in cmd

Is this a memory problem? Have been working on this for a long time... did I run out of memory? I should have around 6gb of memory available.

Or maybe it has to do with my .bat file, it has:

gcc -g myfile.c -o myfile
gdb -q ./myfile

Just wondering about the ./ in front of the executable... is the ./ the problem? Just read somewhere that ./ is important in front of the executable name when running gdb.

How can we make this cursor footprint disappear? Why does it happen? Thank you for reading. :)

Notes: -g flag has gcc create debug info for gdb; -o flag lets me specify executable name; -q flag starts gdb quietly

  • Your image shows some lines that have ‘‘footprints’’ and some that don’t. What did you do differently? – Scott Feb 10 at 0:24
  • @Scott The cursor appears and disappears over and over... I just didn't hold down the <enter> key. :) (Holding <enter> would make the footprint never change.) – unreg Feb 10 at 2:21
  • 2
    @JakeGould Thank you so much for teaching me about how to <kbd>enter</kbd> show keyboard keys! :D – unreg Feb 10 at 2:29

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.