0

I am currently trying to access an Oracle 11g Database via PowerShell using the SOAP API. The first thing I did was to acquire a session token which worked flawlessly, but now I am trying to execute a query against the DB and I face the problem that I cannot specify the service definition from the WSDL I want.

When looking at the WSDL file of the Oracle DB, I can see multiple wsdl:service tags, but when I instantiate a new interface using the New-WebServiceProxsy CMDLet, I can only manage to access the first wsdl:service definition.

To show you what I mean:

<wsdl:service name="SAWSessionService">
<wsdl:port binding="sawsoap:SAWSessionService" name="SAWSessionServiceSoap">
<soap:address location="https://***:***/analytics/saw.dll?SoapImpl=nQSessionService"/>
</wsdl:port>
</wsdl:service>
[...]
<wsdl:service name="WebCatalogService">
<wsdl:port binding="sawsoap:WebCatalogService" name="WebCatalogServiceSoap">
<soap:address location="https://***:***/analytics/saw.dll?SoapImpl=webCatalogService"/>
</wsdl:port>
</wsdl:service>
[...]
<wsdl:service name="XmlViewService">
<wsdl:port binding="sawsoap:XmlViewService" name="XmlViewServiceSoap">
<soap:address location="https://***:***/analytics/saw.dll?SoapImpl=xmlViewService"/>
</wsdl:port>
</wsdl:service>

I can access the SAWSessionService without a problem, but when I try to access XmlViewService it just defaults to SAWSessionService and I get all the corresponding methods.

I have tried using the -Namespace parameter like this:

New-WebServiceProxy -Uri "https://***:***/analytics/saw.dll/wsdl/v6" -Namespace "XmlViewService"

but that does not change anything either.

I have also just used the SOAP interface by utilizing the Postman extension, which worked, so it is a problem with the script. The only difference was, that I used the location the service for my requests, but New-WebServiceProxy seems to autogenerate those.

Am I just missing something?

I would really appreciate any help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.