1

I am trying to set up routers around my place to have wi-fi coverage and security..

Here is the situation: I live with my family in a moderately large property, so in order to have complete wi-fi coverage we need couple of routers to ensure signal strength. Also, we have spare rooms we rent through airbnb, so we have a dual band tplink wr941hp router in order to have a guest wi-fi network set up. Finally, our ISP provides a weak wi-fi router (default IP 192.168.1.254) which we are trying to work around.

What I am trying to do: I have the ISP router wi-fi turned off. TPLink is set as slave: lan-to-lan from the ISP to the TPLink; TPLink DHCP turned off; TPLink IP set to 192.168.1.50 (as per this tutorial). Main SSID is the family wi-fi, and a guest wi-fi SSID set-up.

Problem is, I am unable to connect to the guest wi-fi. I get internet just fine though the family wi-fi, but guest is unable to resolve IP from what I was able to gather (I tried connecting with my laptop and phone. On the android phone, connection stalls at "Getting IP address..." and than fails).

Edit: router info as requested by Tim_Stewart

TPLink WR941HP v2.0 firmware: 2.0.1 build 20180305 Rel. 54795(4252)

Guest WLAN config page screenshot

Can I get some help with this?

  • 1
    Hi @Tim_Stewart, thanks to your commentI seem to have fixed the issue. Since you asked for an image of my guest WLAN configuration page, I assumed something there could have been misconfiged and tried ticking the box on the second line, that read "allow guests to access my local network". I am now able to connect and have internet through guest wi-fi. But I thought that this would compromise my family network security. I noticed I cannot login to the TPLink router from the guest wi-fi.. so maybe I was overzealous? – Guga Figueiredo Feb 12 at 23:14
1

So.. from @Tim_Stewart's comment I was able to find the necessary configuration to get my guest wi-fi working as expected.

On the Guest WLAN page, you have two checkboxes with options:

1 - Allow guests to see each other
2 - Allow guests to access my local network

Ticking the second box has resolved the issue of not being able to connect to the guest wi-fi.

Since I remain unable to access router through guest wi-fi, I am inclined to believe this is not actually exposing my family network to guests, like i thought it would.

New contributor
Guga Figueiredo is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.