0

I'm asking about an issue on a Wordpress website, that serves on an Ubuntu 18.04 behind of a WAF service.

The server was working for 1 year. 4 days ago I tried to upload a file and I got Http error.

upload_max_filesize and other values on configurations are about 2G.

First of all, I checked VM configs and I found out VM memory reduced to 4G. After increasing the memory amount, I did a check on Vestacp for the PHP, Nginx, and Apache configs, and they had no changes. Then I tried to upload, but this time on the local network and file uploaded successfully!

here are the questions:

  • Did I miss anything, while I checked the configurations?
  • Is the WAF the reason of the problem?
  • Is it a possibility that reducing and increasing the VM Memory amount, causing the problem?

And at last, how can I fix this?


Edited

Can someone explain the Juniper strategy and why it has done this?

closed as off-topic by Ramhound, fixer1234, music2myear, Pimp Juice IT, DavidPostill Feb 13 at 17:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is not about computer hardware or software, within the scope defined in the help center." – Ramhound, fixer1234, music2myear, Pimp Juice IT, DavidPostill
If this question can be reworded to fit the rules in the help center, please edit the question.

  • FYI if nothing else just so you know.... wordpress.stackexchange.com – Pimp Juice IT Feb 13 at 13:52
  • We don't know Juniper's strategy. You'd have to ask them. And questions about Wordpress and websites in general are off topic here. Please read the tag wiki for the Wordpress tag applied to your question. – music2myear Feb 15 at 16:18
0

I don't know your exact hosting set up (like if you are using cpanel or another layer in there) .. But I have found this article at https://www.wpbeginner.com/wp-tutorials/how-to-increase-the-maximum-file-upload-size-in-wordpress/ very helpful in the past. Note that some servers I've found I needed to create a php.ini file in the domain root, other times just changing it at the server level worked fine across all domains, and other sites I've needed to use the .htaccess file to get the increased size to work. It's definitely worth checking your waf though, be sure that it doesn't block file uploads or that it doesn't specify a limit.

-1

The problem has solved after bypassing the WAF

** Edited **

According to the network security administrator investigation on the issue, after a couple of malicious requests to the Server, WAF made the right decision by blocking the rest of them. However, we are trying to find the source of the requests. As a theory, MSN Bot doing this.

New contributor
Rmanaf is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • What's that, can you explain with more detail to ensure it stays helpful to others with more clarity. – Pimp Juice IT Feb 15 at 7:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.