I am trying to run windows program (atmelstudio) as administrator through batch command in Jenkins build process. So far I have enabled original .exec and all shortcuts to run as administrator through Windows GUI. But when I run windows BATCH command START /WAIT atmelstudio example.cproj /build release /out build.log it doesn't always run as administrator. When I restart windows build machine and then run this program through jenkins build, it runs as administrator, but in scheduled nightly build it always fail to runs as administrator.

I have tried

runas /user:admin-user@host-name /WAIT atmelstudio example.cproj /build release /out build.log

runas /user:host-name\admin-user /WAIT atmelstudio example.cproj /build release /out build.log

but this didn't help at all.

what I have to do here to make atmelstudio to run as administrator always through batch command ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.