0

I'm using IIS 10 and Windows 10, hosted on my PC at home.

The common answers I was able to find on the web don't seem to help me. Permissions are all okay, firewall port 80 is open, app pool is live. I've tried iisreset as well, and the W3SVC-related services are all running. When I bind the server to all unassigned on localhost:80 I can view it from there, but not from the Internet, which means the application runs fine itself.

The log files show nothing suspicious or weird either. At one point they stopped receiving connection requests, and the log just ends. HTTP 200's and then nothing. The event viewer has no errors or warnings related to W3SVC either. My external and local IP's have also not changed.

For the record, this site worked before, and only recently suddenly stopped with no changes. I don't think I did anything, but I guess it's possible? This is really boggling my mind as usually I can find any kind of solution out there, so any help is appreciated. Thanks!

New contributor
torogadude is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Can you show the IIS site mappings page? I suspect that the site is added with a hostname so is not responding to other names. – shawn Feb 14 at 8:02
0

If your site was previously working from your public IP (internet IP), but now no longer functions, and you are sure that your IP's and servers configurations have not changed, it may be an issue with your router. Check your router still has the port forwarding setting in its NAT section to point port 80 to your servers local IP.

Try connect to your IIS Server's private IP using a web browser on another machine on your private network. If this can't connect it must be a configuration setting with your IIS Server, if this can connect it's probably a problem with your router (or maybe even your ISP).

If you can't connect locally, run netstat -a in an elevated CMD window to check port 80 is listening, but in your situation I assume it is since you can connect via localhost. To pinpoint it to being a IIS issue and not firewall/routing issue you could stop the IIS service and run a simple application like PortListener and configure it to listen on port 80, after doing that telnet to your private IP on port 80 from another machine and see if telnet connects.

Additional troubleshooting steps (but potentially unsafe):

  1. If you can't connect locally - Disable your servers firewall momentarily and try connect via the private IP.
  2. If you can't connect publicly - Disable your servers firewall momentarily and try connect via the public IP.
  3. In your router's NAT configuration set all ports to be forwarded to your servers private IP momentarily and try connect via the public IP again.
New contributor
Jerry Jackson is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Hmm, the port forwarding is still there and unchanged, and I wasn't able to connect internally through the network by going to 192.168.0.XXX:80 from a separate device. My router also does not let me disable its firewall because the port-forwarding automatically makes the exception (I guess?) but disabling the firewall on my computer completely didn't help either. Neither does pointing all the ports. Seems like it's with IIS then? – torogadude Feb 12 at 4:25
  • I have updated my post. Try running the netstat command to check the listening ports, or try running another application like PortListener on port 80 to see if you can connect to that. – Jerry Jackson Feb 12 at 21:32
  • It is common to be unable to connect internally once you forward your ports to that address. You get around that fact by accessing through the external ip address. Are you sure your ISP has not simply enabled a block on the port? – Ramhound Feb 12 at 22:48
  • 1
    @Ramhound I have never experienced this, and I don't understand why this would happen, or why it would ever be desirable for this. Port forwarding is purely meant to be NAT, nothing should be getting blocked. – Jerry Jackson Feb 12 at 23:05
  • Using netstat -a showed me something very interesting: my localhost 127.0.0.1:80 is shown as "LISTENING" over TCP, but the 192.168.0.X for my PC is non-existent. I checked my firewall and router again and everything seems to be good there for the port 80 rules/forwarding, and hasn't been changed at all since before it was working. So where do you think the error is? – torogadude Feb 13 at 2:35

Your Answer

torogadude is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.