0

I have a laptop with windows 7 I'm not using at the moment and want to make vhd images for backup purposes so that the laptop can be used by someone else. While disk2vhd is processing the c drive I get an error message saying:

"The requested operation could not be completed due to a file system limitation."

Following this Technet thread about this error message I defragmented the drive (despite it's on a ssd):

Researching the question indicates the file system (good old NTFS) has a "limitation" such that when the targeted volume is "too fragmented" your read or write will fail.

According to another answer in this thread I checked compression for the drive. The drive does not use compression.

I was copying a 1 Terabyte file to a brand new formated 5 terabytes drive. Message could not relate to fragmentation. In fact, the volume was flagged for NTFS compression. I unflagged the volume and the copy went well.

Edit: I also tried to defragment specific files using the contig tool from the sysinternals suite like suggested in this serverfault thread.

It's very possible that with that many fragments, the filesystem itself is unable to add more fragements. An easy way to test is by using the Contig utility that the other article locked to defragment the files

I found a file with 41 fragments with this tool and defragmented it with no result EndEdit

Edit: found some folders which where compressed with this helpful command provided by this answer for finding all compressed files/folders:

gci -r C:\search\path | where {$_.attributes -match "compressed"} | foreach { $_.fullname }

Unfortunatelly this did not either help.EndEdit

In the eventlog I noticed VSS errors occuring at the time the disk2vhd error comes up.

you may experience multiple instances of VSS Error 8194 in the Application event log. These errors DO NOT generally impact the ability of the program to perform online backups, but often raise questions from system administrators or managed service providers due the error status indicated.

I tried the second solution:

The second (preferred) way to work around the issue is to make an adjustment to the default COM service activation permissions - allowing Network Service (and possibly Local Service) user account(s) to activate the IVssWriter callback interface. This method has the benefit of permanently fixing the issue in one place and allowing the VSS Writer service(s) to run at the privilege level that Microsoft intended. Any COM object accessed (by a process running as Network Service) still has the ability to enforce security restrictions it so chooses.

I couldn't identify any of the services mentioned in the first solution:

The first is to locate the VSS writers (Start | Run | services.msc) that are erring out and change the account they are running under from Network Service to Local System. Then, restart the service process (or reboot the computer) and the VSS Writer will run with max privileges - thereby eliminating the IVssWriter callback errors.

The VSS errors are gone, but the error from disk2vhd is still occuring.

I also noticed in the security event log the following codec related error:

Event ID 6281 System Integrity

Code Integrity determined that the page hashes of an image file are not valid. The file could be improperly signed without page hashes or corrupt due to unauthorized modification. The invalid hashes could indicate a potential disk device error.

File Name: \Device\HarddiskVolume2\Windows\System32\l3codeca.acm

But with the informations described in the technet thread I don't see how this should be related to the disk2vhd operation (except playing the sound for the messagebox?):

hen audio is redirected to the client and we load audiodg, it enumerates the codecs to get information from them.

Not all codecs are signed to load in a protected process and if they are not this error is generated.

I'm using version 2.01 which should be the lates release. And I have ativated both checkboxes ("Use vhdx" and "Use Volume Shadow Copy"). The error also happens when not using vhdx.

The ssd is a Samsung 850 EVO which is, as far as I know, a self encrypting device. I also use Bitlocker. Could this cause the problem? Should I deactivate Bitlocker? Anyway drive d is also located on the ssd and this drive causes no problems in disk2vhd. So I would expect that Self Encryption and Bitlocker shouldn't be the cause for the error message. Edit: Larryc pointed that Bitlocker has to be deactivated according to the tool instructions. So I deactivated it and decrypted the drives. Unfortunatel the error message will continue to show up at the same level of progress while creating the image for drive c. EndEdit

Edit Running Checkdisk didn't solve the problem neither EndEdit

Is it possible to identify with which file or operation the error message is caused? If not... any ideas what else could cause this type of error message in general?

0

Bitlocker is expressively forbidden:

"Disk2vhd does not support the conversion of volumes with Bitlocker enabled. If you wish to create a VHD for such a volume, turn off Bitlocker and wait for the volume to be fully decrypted first."

See: https://docs.microsoft.com/en-us/sysinternals/downloads/disk2vhd

| improve this answer | |
  • Thanks, I'll try that. It's just strange that disk2vhd had not such problems with my other drives (D & E) which are also encrypted with bitlocker... – Onsokumaru Feb 12 '19 at 12:37
  • So I decrypted the drives and I still get this error message. – Onsokumaru Feb 13 '19 at 8:17
0

I found the solution for this disk2vhd problem.

Actually I was just "looking into the wrong direction". I thought the error message is raised by a problem on the drive disk2vhd is copying, but it was raised by the destination drive where the vhdx files were written.

I didn't check this drive, but it had compression turned on. Turning it off solved the problem. I assume the turned on compression did cause some problem with the file which couldn't be handled. I guess it was the often mentioned count of fragments for the vhdx file.

So conclusion is to check also the destination, not only the source ;-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.