0

I recently got INTEL NUC Barebone (BOXNUC8I3BEH2) and installed Windows 10 Pro on Intel 2.5in 80GB SSD drive. All working perfectly. Then I tried to add ADATA SU800 128 GB M.2 SATA disk. The M.2 slot is enabled in (latest version of) BIOS.

When I insert the M.2 disk and boot, the orange HDD activity LED lights up and nothing else happens. I get nothing on screen so it is difficult to say what went wrong. I tried booting with and without the other drive. I also moved the ADATA SU800 to another PC (ASUS TUF H370) and it booted fine, I was able to see the disk and erase it from BIOS. So I assume that the disk is operational.

The ADATA SU800 is not on the Intel list of validated disks for this NUC, so I wonder if I should get one of the supported disks instead. I do not have any other M.2 drives at hand to try it out.

Could it be someting obvious I have misconfigured in BIOS?

EDIT: I can get to BIOS settings and also boot to Windows with both disks installed. The issue with seeing "nothing on the screen" may be related to the HDMI control. When I insert the M.2 and start the NUC, the screen does not wake up, so I have to switch the display off and on to get it working. The orange HDD activity light however switches on and stays on, so it does not work as activity light any more.

So my actual problem(s) with this M.2 disk seems to be that the HDMI does not wake up the screen and HDD led is on continuously. Using 2.5in SSD alone works fine, the HDD led blinks on disk activity and HDMI works as expected.

2 Answers 2

0

Sounds like you did most of the work already. I'd look towards the BIOS / UEFI for your system and ensure it allows legacy boot.

1
  • Thanks, tried that, however it made no difference. I also edited my question - it is possible that the NUC box actually booted into Windows but I simply had no picture on the screen. That combined with frozen HDD light gave me impression that the system is frozen. Feb 12, 2019 at 22:04
0

The solution was to replace the ADATA SU800 SATA with a KINGSTON SSD M.2 2280 240GB PCIe disk which is listed as supported. The SATA M.2 kept acting funny but now the HDD LED blinks on disk activity and all works fine. Reinstalled Windows 10 on new drive as well.

What I take away from this - sometimes it may be worth to check manufacturer hardware compatibility list if such exist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.