I just got a ThinkPad T510 with Windows 7 Professional and I installed Daemon Tools Lite, but I keep getting an error when I run it:

Unable to add adapter.

I can't load iso images, because there is no virtual drive. I tried starting it as an administrator, it tried to update the virtual devices, and it got the same problem. Does anybody know how to fix this?


OK, here is how I solved the problem for Windows 7:

  1. Uninstalled Daemon Tools.
  2. Uninstalled SPTD.
  3. Removed legacy SPTD keys from the registry.
  4. Re-installed SPTD before installing Daemon Tools.
  5. Installed Daemon Tools Lite.

Here are the resources that I used:

  1. For Daemon Tools SPTD issues: http://daemonpro-help.com/?id=932
  2. This shows how to clean up the SPTD registry keys and install SPTD by itself (without Daemon Tools): http://geekswithblogs.net/apopovsky/archive/2009/08/14/re-installing-daemon-tools-lite-and-sptd-on-windows-7.aspx
  3. You can download the latest SPTD by itself here: http://www.duplexsecure.com/en/downloads
  • Thanks for that, although you might have gone a little overboard. Windows 7 64-bit - All I had to do was install the latest version of SPTD (64-bit) manually, then re-install Daemon Tools and the problem was solved. No messing around in the registry needed. – user56382 Nov 21 '10 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.