2

So this is an odd one...

I need to run the 64-bit version of command prompt/powershell as non-admin. Unfortunately, no matter what I try, it will only run in elevated mode.

From what I've seen, in the system32 folder cmd and powershell are set to run as admin upon open while in the sysWOW64 folder they run fine. While the 32-bit works, it does not work for the script I need to run; therefore, I need the 64-bit command line to work.

  • OS: Windows 7 64-Bit Enterprise

  • Domain computer

  • Domain GPO is not the issue, as this is the only computer with the problem.

What I've tried:

  1. "Disabling" UAC, and while it no longer prompts it still only runs as admin, which doesn't help as I need to run it in a non-elevated mode.

  2. Run as different user, leads to access error (i.e. not able to open command line program, as admin needed)

  3. Compatibility mode is grayed out, but even checking the settings it is not set to run as admin.

  4. Shortcuts also open it up automatically in elevated mode. So problem lies in the target location, and changing the shortcut does not fix the issue.

Is there a way to allow it to run as a regular user?

  • How are you starting Powershell? Is the shortcut you're using set to always elevate? Is the issue that when you open PS "normally" it always prompts, or that it does not open UNLESS you open it with elevated permissions? – music2myear Feb 13 at 18:32
  • I don't know if this is the same thing, but it's similar and worth reading: superuser.com/questions/463434/… – music2myear Feb 13 at 18:34
  • I'm running Powershell from the start menu by searching it. It is the direct exe file (not a shortcut), and automatically runs in elevated upon open. Upon searching it it shows that the little window shield the signifies "Run as admin" – user997967 Feb 13 at 18:35
  • What about this? Maybe you can find your solution here – lucaortis Feb 13 at 18:40
2

So figured it out after trial and error.

Apparently, it was just something in an unstable state with UAC.

I disabled UAC, and then restarted. I then re-enabled UAC at max level then restarted again and it worked.

  • Thanks to @lucaortis... still 0 sense on how that works... – user997968 Feb 13 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.