In January Windows 10 updated and reactivated my MSI laptop's touchpad. Since then I have been unable to disable it. Here are the things I have tried:

  • Windows>Touchpad settings>Disable

    This no longer exists on Windows 10. There is no option to disable it - you can only change the sensitivities.

  • Downloading a 3rd party control panel

    "Synaptics control panel" will not download through the Windows play store - instead it just states "Error". I have also tried to download control panels from 3rd party websites but these either no longer exist or no longer work when I try to get them.

  • Uninstalling the driver

    By going into the "Device Manager" I can see the driver (Synaptics SMBus Touchpad) and can view its properties. Through this I cannot disable the device (the button is blanked out) but I can uninstall it. This used to be successful for about 24hrs until Windows realized and reinstalled the driver. Now it re-installs the driver the instant the computer restarts (and won't disable the touchpad without restarting, so I cant win). I have also clicked the "Delete driver software for this device" button when uninstalling it but it makes no difference.

I'm at the point where I'm going to manually disconnect the touchpad from the motherboard to remove of its use, it interrupts my coding and is extremely frustrating...

  • "Synaptics control panel no longer downloads" - What does this mean exactly? Please edit your question instead of submitting a comment
    – Ramhound
    Feb 13, 2019 at 21:50
  • Have you tried disabling it in Device Manager?
    – essjae
    Feb 13, 2019 at 23:39
  • Yes, the "Uninstalling the driver" action was when I went into device manager, uninstalled the driver entirely and ticked "delete the driver software" box. The option to "Disable" is blanked out on the properties, I can never disable it
    – Maxmansung
    Feb 14, 2019 at 0:14

3 Answers 3


Hello i had the exact same problem. For anyone coming across this post like me, I got rid of the touchpad by changing the driver to the ELO TouchSystems USB Touchscreen. You can do it in device manager. Open up properties of the synapsis driver, hit the update driver button, choose the driver location from the computer, uncheck the box saying u want only compatible drivers and pick the non compatible Elo driver.


I ended up doing exactly what you didn't want to resort to. Ripped the ribbon straight off the motherboard, no regrets, perfect brutal solution imho. MSI's drivers are honestly shamefully bad.

None of the other solutions on here worked.



Just done this after beating myself up for WEEKKKKS!!!

Absolutely works on my HP 255 G6 Notebook

It really was doing my head in!

Follow the instructions - very straightforward. Read all the way through rather than jumping the gun like I did. They give you the order of what to do. I can't thank whoever published enough. Would have been better had it not been necessary but at least we now have a solution. Stu

  • 3
    Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Machavity
    Nov 26, 2020 at 18:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .