7

I am a new Mint Linux user and I found that all applications are groped. I don't like this kind of grouping. I would like to remove all grouping. Please check the screenshot. There are 5 terminal and 4 IntelliJ application running. I want to see all in the taskbar no grouped together.

enter image description here

Pls let me know how to do it?

1
  • If you search the programs menu for settings or panel or window or cinnamon, does anything relevant come up? Or right-clicking on the taskbar? I'm not using Cinnamon right now, but on XFCE right-clicking or searching for settings or panel eventually leads to panel preferences, then the Window buttons settings and "Window Grouping: Never or Always" – Xen2050 Feb 15 '19 at 8:49
12

Right click on the panel, go to "+ Add applets to the panel". The applet, "Grouped window list" should be removed, it is the one that adds the grouping that annoys both of us. You then need to add the applet, "Window list" to get the old way back.

FWIW when I did this it worked the old way but the spacing was very broken. Between the menu and the window list there was a big gap, I reduced it by adding the "spacer" applet, but only somewhat. The quicklaunch icons are to the left of the window list now too, can't figure out how to fix this one....yet. In any case it is annoying but still far better than the Windows X inspired annoyance.

  -Charlie
2
  • 1
    You can left-align the quick launch icons and window list by using the dconf-editor (install with sudo apt-get install dconf-tools). Open donf-editor and navigate to org > cinnamon > enable-applets. Look for the string panel1:center:11:window-list@cinnamon.org and change it to panel1:left:11:window-list@cinnamon.org. Originally from: forums.linuxmint.com/… – Will Keeling Apr 30 '19 at 7:49
  • omg, it's a bliss to see all my Chrome windows – iosifv Jan 8 '20 at 13:02
3

As of Mint 19.1, this can be done from the Welcome screen (search 'welcome screen' in the search bar of your menu)

On the left, select First Steps, then under the Desktop Layout section in the main window select Traditional. You'll probably have to re-create any shortcuts you had.

Remove application grouping in Linux Mint

1
  • Simple and easy way to fix the panel functionality to be as before. – ajaaskel Apr 5 '20 at 10:11
0

Fedora 30:

sudo dnf install dconf  dconf-editor

and then the aforementioned:

  • Open dconf-editor and navigate to org > cinnamon > enable-applets

  • Look for the string panel1:center:11:window-list@cinnamon.org

    and change it to panel1:left:11:window-list@cinnamon.org

In this example, the number (11) also seems to be the order from the left. So the window list would be the 11 from the left. I have the app launcher at position 1, and the windows list at 2 from left.

1
  • What does this have to do with app grouping? – rtaft Aug 20 '20 at 12:34
0

In Linux Mint 19.3 (cinnamon) you can just to tell the "Grouped window list" app not to "group windows by application". The advantage is for example that you can enable it back without it jumping on the right side of the panel and you have some more settings.

Right clock on the panel, go to "Applets", search for "Grouped window list" (type just "window" in the search) and tap "Configure" (gear wheels on the right). Deactivate the "Group windows by application" - and be happy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.