0

For some reason I'm unable to mount a directory within docker on Linux. The odd thing about this is that I managed to get it working under Docker for Windows, using the same docker image and setup.

The image I'm using is WSO2 Enterprise Integrator. I'm using version 6.4.0 and try to add my own config from the host machine. I try to run the image using the following command:

docker run -it -p 8280:8280 -p 8243:8243 -p 9443:9443 --name integrator --volume /home/ludo/development/docker_config/wso2/conf:/home/wso2carbon/wso2ei-6.4.0/conf wso2/wso2ei-integrator:6.4.0

I made sure the settings were done correctly (by using chmod o+r on the entire conf directory) but no matter what I try, I always get the error stating:

sed: couldn't open temporary file /home/wso2carbon/wso2ei-6.4.0/conf/axis2/sedZmvviu: Permission denied

Note that I tried running this command as the root user as well by sudoing. I made sure during the docker setup that the user as specified (i.e. ludo in this case) was added to the docker group. I have therefore been able to run any other machine, including portainer using data volumes.

I have tried to use both the mount command as well as the volumes for this trick. Essentially I would like overwrite the conf directory on the guest system with the one on my host, making sure I can locally set configuration and ensure config persistence.

Any help would be appreciated.

  • This question is slowly becoming my second Tumbleweed award..... – Ludo21South Feb 18 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.