0

When I try to install PowerCLI in PowerShell with the command : Install-Module VMware.PowerCLI

I get following error message :

PackageManagement\Install-Package : Für die angegebenen Suchkriterien und den Paketnamen "VMware.PowerCLI" wurde keine Übereinstimmung gefunden. Verwenden Sie Get-PSRepository, um alle verfügbaren, registrierten Paketquellen anzuzeigen. In C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:1809 Zeichen:21 + ... $null = PackageManagement\Install-Package @PSBoundParameters + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (Microsoft.Power....InstallPackage:InstallPackage) [Install-Package], Ex ception + FullyQualifiedErrorId : NoMatchFoundForCriteria,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPackage Blockquote

1
  • Where is the source package located? Feb 15 '19 at 19:29
0

Check your repo

PS /> Get-PSRepository

Name                      InstallationPolicy   SourceLocation
----                      ------------------   --------------
PSGallery                 Untrusted            https://www.powershellgallery.com/api/v2

Then try to install again

PS /> Install-Module -Name VMware.PowerCLI

If possible, give us the ENGLISH error message, I don't know what your error message is talking about, maybe my reply is totally out of subject...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.