0

I'm trying to create a virtual assistant in azure by following this guide: https://github.com/Microsoft/AI/blob/master/solutions/Virtual-Assistant/docs/virtualassistant-createvirtualassistant.md

but when running the msbot clone services following message appears in the console:

With msbot 4.3.2 and later, the only AZ CLI prerequisite is having an AZ CLI version >= 2.0.53. If you have the botservice extension installed as well, please remove this via "az extension remove --name botservice". Checking az botservice version You need to upgrade your AZ CLI version to >= 2.0.53. You can install the latest AZ CLI from https://aka.ms/az-cli-download

Initially I was using msBot v4.3.2 and azure-cli v2.0.55. Then I've installed version 2.0.53 via pip install azure-cli==2.0.53 after uninstalling version .55, but still getting the same error. Also tried already lower msbot versions, but issue still remained.

I've also checked this post but it didn't helped with a workarount.

actual Console version check:

C:\Program Files (x86)\cmder
λ msbot -v
4.3.2

C:\Program Files (x86)\cmder
λ az -v
azure-cli                         2.0.53 *

Does anyone has an idea what to do here?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.