3

Windows Explorer started randomly crashing when browsing files/folders, becoming worse over time, and it's now to the point Explorer continually crashes every few seconds from the moment I log in, with the TaskBar flashing and unresponsive. I can't open any programs, and if I launch Task Manager, it closes immediately when the TaskBar flashes again.

  • I booted to Safe Mode, but the same thing occurs
  • Sfc /ScanNow completed successfully in Safe Mode, but the problem persists

3 Answers 3

3

The problem seems to have been a bad thumbcache.db within %LocalAppData%\Microsoft\Windows\Explorer, and after renaming the Explorer directory, everything works fine when I boot Windows normally.

2
  • 1
    Thank you! After hours of various attempts, this finally fixed the problem for me. How did you find out it was a bad thumbcache file?
    – Russell G
    Aug 30, 2019 at 14:47
  • @RussellG I don't remember how I figured it out. Sorry.
    – Aaron T
    Sep 3, 2019 at 15:43
1

Ctrl+Alt+DelTask ManagerStartup tab → Disable Microsoft OneDrive

0

It may have to do with the Windows 10 settings for thumbnail preview databases, which can be verified by logging into another account to see if that account is also affected. For me, an .odt file within %UserProfile%\Desktop or a folder with a shortcut to Deskop was the cause, with the solution being to move it to %UserProfile%\Documents.

  1. A workaround may be to create a new account:
    1. Ctrl+Alt+DelTask Manager → File → Run new task → compmgmt.msc
    2. Local Users and GroupsUsersActionNew User...
    3. Right-click newly created user → PropertiesMember OfAdd...Administrators
  2. Terminate the current session, boot to Safe Mode, and login with new user
    1. Copy the %UserProfile%\Desktop folder to the original user's Documents folder
  3. Stop Windows 10 from using thumbnail preview icons for folders

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .