0

I have flashed Linux Mint onto a USB stick and tried to install it on an Acer Aspire A315-41 laptop.  Running live Linux Mint got me this error:

Firmware Bug: AMD-VI IOAPIC[4] not in IVRS table
Firmware Bug: AMD-VI IOAPIC[5] not in IVRS table
Firmware Bug: AMD-VI no southbridge IOAPIC found
AMD-VI: Disabling interrupt remapping
watchdog: BUG: soft lockup - CPU#0 stuck for 23s!

And then the last line loops, changing the number of CPUs; it tries with all 8 of them and then starts from zero.  By running the live version in compatible mode I managed to install it, but now on boot the same error happens.  I've searched around a lot but no fix works for me.  How can I fix this?

  • Have you tried booting with IOAPIC=off ? – Eugen Rieck Feb 17 '19 at 15:14
  • Yes, pressed e on boot option, added it as parameter in the beginning and booted with f10. Same error screen appears – Dillon Wreek Feb 17 '19 at 16:05
0

If you upgrade your bios (UEFI) to v1.15 then it will boot without you having to do any overrides and it should boot your live Linux Mint. If you use an older bios then you need to add some overrides at boot, normally this is done with your boot loader. With grub you can add this to /etc/defaults/grub or where it's located in your distribution. GRUB_CMDLINE_LINUX_DEFAULT="ivrs_ioapic[4]=00:14.0 ivrs_ioapic[5]=00:00.2" That will override the bad IOAPIC IDs in older bios and you should be able to boot with full functionality. Since you used a Live distributions i think you be better of if you upgrade the bios but it's possible to add custom boot options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.