0

When typing in Sinhala in Word 2010, a tiny pop-up box appears in the top left corner (it can be moved anywhere else) with the last few keystrokes. There is a green left-downwards pointing arrow to "Finalise the string" (this text appears if you hover over the arrow).

When I type "සිංහලා" ("Sinhala"), "සිං" is automatically "finalised" and appears in the document, then "හලා" ends up in the box. It seems related to an issue in Windows 10 that the last word/part of a word disappears when I change from Sinhala back to English, if I don't type a space, or move the cursor first. E.g. in any program other than Word, after typing "සිංහලා" and nothing else, "හලා" disappears when I change back to English, just leaving "සිං".

What is this feature and how do I get rid of it to type directly in Word? I've never seen this in any other program, including Excel 2010. I have the සිංහලා (Sinhala) Language pack installed.

Finalise the string

It seems this box is part of IME. Word help says:

Turn Japanese Input Method Editor (IME) on 101 keyboard on or off.

Alt+~

Turn Korean IME on 101 keyboard on or off.

Right Alt

Turn Chinese IME on 101 keyboard on or off.

Ctrl+Spacebar

As expected, none of these work for the Sinhala keyboard.

1

Uninstall the Sinhala language package from Windows 10. enter image description here

Then install the Windows 8.1 IME to Windows 10 http://www.gurulk.com/download-sinhala-tamil-language-kit-ime.php

Now you can directly input Sinhala as needed.

0

This is not a real solution but I think it could help. For anyone want to stick with your language IME for everything but at the same time use default english input in some specific apps:

(Windows 10) Settings -> search for Language -> "Choose an input method to always use as default" -> Check the box "Let me use different input method for each app window"

Now go to your app window that you dont want to use IME, select the input language in taskbar as English (default). And window will remember your preference for that app even after you close and re-open it.

Hope this help.

0

Download the Sinhala Tamil Kit and install http://www.gurulk.com/download-sinhala-tamil-language-kit-ime.php

1
  • 2
    I used to use the Sinhala Tamil Kit on Windows XP. Do you have evidence that this fixes the problem on Windows 10? – CJ Dennis Sep 4 '19 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.