My SSD crashed and I had to restore the OS from a System Image. Much better than having to reinstall Windows but the major hurdle I've had is that Eclipse isn't working.

I already had Eclipse installed but when I tried to run it I got this error message:

Eclipse Error Message

(username redacted)

I've already made sure that Java is installed correctly by checking on Command Prompt. This is the information it provides:

Java Version

As you can see it's version 1.8 so I'm pretty sure that's not the issue.

I made sure to download the Java SE Developement Kit 11.0.2 since at one point it said I was missing the development kit. I'm not sure if it was the same one I had before but it's supposed to be the latest version. Or perhaps I'm supposed to be using a different one? If so it could be causing the issue but I'm not sure.

I decided to reinstall Eclipse to see if that cleared the issue.

I downloaded and tried using eclipse-inst-win64 to reinstall Eclipse but I got redirected to this page: JRE MISSING

I was able to find someone who had a similar issue. Perhaps it's the key to fix this. Their issue was posted and resolved on this page: Eclipse Not Installing

It talks about editing the eclipse.ini file to specify the file path in case that's the issue. Perhaps that's what's causing the above issue? Here's the text inside the eclipse.ini file:

-startupplugins/org.eclipse.equinox.launcher_1.5.200.v20180922-1751.jar--launcher.library plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.900.v20180922-1751-productorg.eclipse.epp.package.java.product-showsplashorg.eclipse.epp.package.common--launcher.defaultActionopenFile--launcher.defaultActionopenFile--launcher.appendVmargs-vmargs-Dosgi.requiredJavaVersion=1.8-Dosgi.instance.area.default=@user.home/eclipse-workspace-XX:+UseG1GC-XX:+UseStringDeduplication--add-modules=ALL-SYSTEM-Dosgi.requiredJavaVersion=1.8-Dosgi.dataAreaRequiresExplicitInit=true-Xms256m-Xmx1024m--add-modules=ALL-SYSTEM

I really don't see a file path I could edit if that's what could fix the issue otherwise I would have tried it already. Or perhaps I'm looking at the wrong .ini file but I highly doubt that since it's the only eclipse.ini file.

I'm hoping I have provided at least enough information that I can be guided in the right direction.

Update: I was able to get the eclipse-java-2018-12-R-win32-x86_64.zip folder to try to run Eclipse with that but I got the same error message as before.

Update: I've tried moving the eclipse folder into the Programs Folder but I still get the same error message just with a few different file paths:

Eclipse Error 2

1 Answer 1


I'm pretty sure what went wrong now. For some reason the newest JRE isn't working with Eclipse, or at least that's what it seems like. I used ninite.com to install the other two versions of the JRE. Now both Eclipse and the installer work just fine.

I hope this helps for someone else that has the same issue in the future. Hopefully Eclipse is updated to work with the latest JRE, which is 11.0.2, this year.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .