I am stumped. I have a Dlink PoE switch connected at point A. There is an Ethernet socket at point B which is connected to point A through a cable running between walls. I have recently run a 50m CAT6e cable from point B to point C.

I had an Archer C9 gigabit router plugged into Point B through a very short CAT5 cable. Had a Gigabit connection.

Last night, I put the Archer C9 router at point C. I plugged in the other end of the CAT6e cable into the RJ45 port at point B. I could achieved only a 100mpbs connection with a 0.5% packet loss. (In effect the C9 was connected the the Dlink switch at point A)

I bought back the Archer C9 to point B as before but now could only get 100mbps. Then I tried to plug in a Unifi UAP at point C which the C9 at point B. The Unifi connected at 100mbps to the C9. Then I tried the switch at point B, connecting it to the Unifi through the single CAT6 wire. I had power over Ethernet but no data link.

Then I tried directly connecting the POE switch at point A and Unifi at point C (removing the C9 in between at point B) and had a gigabit connection. Then I took the Archer C9 to point C and couldn't get a connection at all. I tried another old Cisco 100mbps switch at point C which worked fine but only when connected to certain ports.

Then I tried twisting the cable (literally twisting it near the RJ45 connector) before connecting it to the router and viola: gigabit. When I tried a different port on the router, I lost connection again. Then I went to the switch and twisted the cable at that end too and now I am currently connected at gigabit.

What seems to be the problem here?

TL;DR Different switches at different points connect/don't connect and different speeds. I can't figure out why. Twisting the cable ends somehow helps.

I've tried to use different colors to denote the different scenarios I have tried

Most likely culprit

Edit: I have added a picture of what I think is the most likely culprit. After removing the plate and trying to "fix" it, I only get 10Mbit connection now. I'll have to arrange to get the cable reterminated at both ends and see if that helps at all. Also: the Cable is a PONY 5 pair cable which I have connected to 7 other devices at other outlets throughout my house at 1Gbit. So it does seem like the cable CAN carry Gigabit.

Yesterday, I was getting speeds of 650Mbits on Iperf3 using with one device connected to a Unifi UAP connected to point A and desktop at point C. I had no packet drops. Unfortunately, the cable connected to the plate came loose while moving boxes and went back to 100Mbit and now 10Mbit.

Also. The new CAT6A wire suddenly seems to work fine. No problem in connection between those two ends. Issue is with point A and B which involves the old wiring.

When I try to force 1000mbit on the switch, I get any of the following diagnostic results:

1) All pairs OK (POE works, no data) 2) Pair 1, 3, 4 OK Pair 2 Open cable 95meters 3) Now Pair 1, 2, 3 OK Mismatch in Pair 4 15meters

  • 3
    Please draw a diagram and review your wording - this question is very difficult to follow in its current state.
    – Attie
    Feb 18, 2019 at 17:56
  • 6
    It sounds like the signal quality is poor / marginal, and applying physical pressure / torque to the connectors is affecting the signal quality dramatically. I'd suggest re-terminating all points, being careful to untwist the pairs as little as possible.
    – Attie
    Feb 18, 2019 at 17:58
  • 4
    Also - "CAT6e"? superuser.com/a/886409/707676
    – Attie
    Feb 18, 2019 at 17:58
  • 6
    100 Mbit/s will operate over two pairs, 1 Gbit/s will typically operate over all four pairs - so I reiterate my earlier point: try re-terminating all points.
    – Attie
    Feb 18, 2019 at 18:31
  • 7
    Also note the times of day when you are executing these tests and any other activity that may be going on. 20 years ago I had a customer with random data loss problems like you describe. It turned out that a few of the cable runs were too close to an electrical conduit used by the HVAC. Whenever that kicked on, the electrical attenuation would destroy the data going through that line.
    – StingyJack
    Feb 18, 2019 at 22:05

4 Answers 4


This was a very long question with a lot of detail to receive what seems like the obvious answer.

One or more of your cables or connectors are bad.

Get a cable tester and start eliminating where the problem is.

  • Thanks. The cable diagnostics in the Switch currently connected at gigabit speeds shows all pairs OK. No packet drops or spikes. Would that be possible for a bad cable? The cable does stop working when plugged into certain other ports.
    – uberqe
    Feb 18, 2019 at 19:22
  • 7
    Yes. It’s an intermittent connection. You need a tester. Then you can wiggle the cables and connectors and find all the bad spots. @uberqe Feb 18, 2019 at 19:23
  • 1
    Thanks. The connection from point A to B is going to be impossible to wiggle. A bad cable will probably mean I'll have to get new cables. The other alternative is let it be after finding the perfect position--until it goes bad.
    – uberqe
    Feb 18, 2019 at 19:25
  • 6
    @uberqe You can always just cut the connectors off and crimp on new ones. Takes two minutes and can save you the grief of replacing the cable if it's just the connector head that's bad. Unless you bought a cheap pre-made fake cable from ebay or something that isn't really Cat6.
    – J...
    Feb 18, 2019 at 21:40
  • 1
    Exactly. If physically wiggling the heads and/or cables causes variability, that suggests poor contact or breaks/weak spots within the cables and/or connectors and thus that they are Bad. Feb 19, 2019 at 10:04

I had something like this happen to me. In my case there were two categories of issues: electrical and electromagnetic. The electrical issues went away by grounding both stations and the cable, and I do not think they're in play here - PoE I guess means that you only have one wall outlet in play (but then again, you might perhaps also be seeing insufficient power supply acting up over longer distances?).

In my case the cable was also acting as an antenna and picking up garbage. This didn't manifest in lost packets but in an inability to negotiate higher speeds. Perversely, when someone was standing near the hub, and thus probably disrupting the local electromagnetic field, everything was good - but as soon as he walked away, speed dropped or the connection died altogether.

After a long and thankless afternoon, a colleague finally found a heavily shielded cable that worked no matter what.

I think cables, ports, connectors and equipment are fine.

(Maybe not wonderfully excellent, but good enough for normal circumstances).

Why do I believe this: you say that you tried different ports and connectors, and you twisted both ends of the long cable. There is no single combination of port, twist or device that uniquely identifies a non-gigabit / gigabit connection, and when the connection works, it works. If it was a lousy contact you wouldn't see this exact behaviour (granted, the behaviour would be similar). If a connector or a welding was bad at one side, that could never be "cured" by twisting the opposite side of a long cable. And yet it worked for you.

So I think it must be the cable, but not through a faulty connection - it is either the shielding or some other weird effect. For example - and after a certain experience, I wasn't surprised at all - I couldn't connect reliably the two ends of my own home by running a 20m cable in the appropriate duct running inside the wall, I had to force the cable behind the wooden shoe running on the opposite side of the wall (later on, I replaced that cable with two PowerLine adapters). Any conducting wire on my east wall will gather enough current to make network cards and switches just plain go crazy.

  • 1
    I've seen similar effects several times. Once it was an ethernet cable running inside a wall parallel to a power cable. Hardly worked at all, yet the cable itself was sound and the connectors too. Another time an ethernet cable and power extension cord were simply lying on the floor next to each other for a few meters. Moving either of them resulted in proper network connectivity, but as long as both were next to each other - no network at all. And yet, other times, similar setups have had no problems.
    – Vilx-
    Feb 20, 2019 at 0:15

The cable could have been damaged at a spot next to the RJ45 connector, and twisting it might align the remaining wires to have a better contact with the connector

  • 1
    That would have made sense if the issue was only when connecting point A to B or B to C or A to C. I've been experiencing connectivity issues of a similar kind with a variety of devices between AB, BC and AC.
    – uberqe
    Feb 18, 2019 at 17:47

I would have to play with the setup a bit, but I would say re-terminate. Cat5e isn't as finicky, but cat6 needs to have the twists intact right up to the RJ45. Notice that in cat6 two pairs have a tighter twist, and they are opposite in the seperator. This helps reject noise and interference and increase data speeds, thats why untwisting the wire too much will cause issues.

Also, make sure your port speeds are matching.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .