If I am in edit mode in a cell, JupyterLab overrides the find shortcut Ctrl + F. If I go into command mode, I can type Ctrl + F and use Chrome's find functionality.

How can I disable JupyterLab's override of the Ctrl + F shortcut while in edit mode, so that only Chrome's find is used?

  • I don't have enough reputation to create a jupyter-lab tag. If someone could do that, it would be much appreciated, as JupyterLab is separate from (though similar to) Jupyter Notebook. Feb 18 '19 at 22:03
  • 3
    Bump, I'm having this issue and it's super annoying.
    – Ulf Aslak
    Mar 20 '19 at 11:42

Under "Settings" > "Advanced Settings Editor", select "Keyboard Shortcuts" and in the "User Preferences" panel paste the following to disable the JupyterLab advanced document search. This will open a per-cell regex search on the first press, but a double Ctrl+F will open the browser search box as requested.

    "shortcuts": [
            "command": "documentsearch:start",
            "keys": [
                "Accel F"
            "selector": ".jp-mod-searchable",
            "disabled": true

It seems there's no way to disable the Ctrl + F behavior of JupyterLab.

Instead, if you type Ctrl + F again in the cell search mode, you can enable Chrome's search functionality.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.