2

My company's MS Exchange admin has reset my password and given me a one time password. I changed it to a new password and then updated it in:

  • My iPad Mail app.
  • My Android Outlook app.
  • My Mac's Mail app.

The iPad and the Android phone were able to connect with the new password without issues. My Mac, can't. It keeps telling me that it's:

Unable to verify account name or password.

Any pointers?

enter image description here

| improve this question | | | | |
  • 1
    Did you entirely remove the account and re-add it? – music2myear Feb 19 '19 at 17:39
  • Have you tried deleting the password from Keychain Access? – Yuki Sun Feb 20 '19 at 1:55
  • Thanks @music2myear, I tried that like 5 min after posting this question and it worked. It's really silly that Apple's Mail app on an iPad will pick up the new credentials without issues but the equivalent on a Mac won't. Anyway, if you'd like the points, just post that as an answer and I'll select it as the correct one. – Mig82 Feb 20 '19 at 9:22
  • I think it just happens from time to time on any Apple device. I suppose a few hundred iPhones and if entering the pwd doesn't re-connect the account, removing the account and then re-adding it to the device does the trick. – music2myear Feb 20 '19 at 16:14
3

I support a few hundred iPhones and get this issue from time to time. I'd guess the root issue is in the shared code for the Apple Mail app.

The fix is to remove the account from the device entirely, and then re-add the account.

Depending on how you are syncing the mail, you may wish to backup or save the currently downloaded mail before removing the account, either to prevent mail from being lost, or to minimize the amount you have to download again.

I don't know why this happens, just that this fixes it when it does.

| improve this answer | | | | |
0

I know this answer may come a bit late. I have the same issue every 6 months when the administrator settings require the user to change the password. I change it online in my webmail and then, but not immediately, the mail client on my Mac would't accept the new pw. I figured out that you must set the new password in the actual settings of the account within the Mac mail client. Do not use the pop up screen that request your password.

go to mail - preferences - accounts - account details tab and enter the new password. That solved my issue and I no longer need to remove/install the account again.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.