0

I've got a dd-wrt Linksys WRT3200ACS router working in 'AP' mode. My ISP supply a modem which runs a DHCP server. The modem is connected to the LAN port on my router and then the rest of the wired LAN is connected on the other ports. The router pumps out wifi. All other devices (wireless and wired) on my network work online perfectly.

From the router itself, in the shell, I can't seem to resolve DNSes. DNSMasq is disabled and Local DNS setting is 0.0.0.0. I can ping IP addresses on the internet directly, so it definitely has a working connection.

I've tried updating the local DNS setting in the dd-wrt frontend to both that of the ISPs modem (this is what all other devices get from DHCP) and also to 8.8.8.8 for Google's. Neither of these work.

root@Linksys-WRT-ACS3200:/tmp/mnt/sda1# ping google.com
ping: bad address 'google.com'

root@Linksys-WRT-ACS3200:/tmp/mnt/sda1# ping 216.58.198.110
PING 216.58.198.110 (216.58.198.110): 56 data bytes
64 bytes from 216.58.198.110: seq=0 ttl=57 time=6.897 ms
64 bytes from 216.58.198.110: seq=1 ttl=57 time=5.722 ms
64 bytes from 216.58.198.110: seq=2 ttl=57 time=5.784 ms
64 bytes from 216.58.198.110: seq=3 ttl=57 time=5.592 ms
64 bytes from 216.58.198.110: seq=4 ttl=57 time=5.658 ms
^C
--- 216.58.198.110 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 5.592/5.930/6.897 ms

Any ideas? Many thanks.

  • since your modem is doing dhcp, try disabling dhcp in the router. – Moab Feb 19 at 19:43
  • Hi Moab. The DHCP Server is already set to 'Disabled' in dd-wrt. Thanks. – Jeff LeCoat Feb 21 at 10:26
  • I'm voting to close this question as off-topic because the user went back to stock Linksys firmware leaving nothing left to be answered. – Tim_Stewart Feb 25 at 21:26
  • Hi Tim. 'User' agrees. – Jeff LeCoat Feb 27 at 9:58
0

Your WRT3200ACS isn't asking for a DHCP lease from your ISP router. As such, it isn't getting any DNS servers or any other service information either. The WRT3200ACS will not request any DHCP lease from its LAN ports, and this is fine for what you are doing.

When you plug your ISP router into the LAN port of your WRT3200ACS, you should stop considering the WRT3200ACS to be a router and think of it as a switch instead. It doesn't matter if the WRT3200ACS can ping anything or if the router has DNS. The only thing that matters is if every device connected to the WRT3200ACS can see the ISP router. The ISP router should, functionally speaking, be your primary and only router. Park the IP address of the WRT3200ACS on an IP outside the DHCP range of your ISP router. Disable any services on the WRT3200ACS that might cause a router conflict, nominally DHCP.

Yes, you can configure dual routers with advanced router software like dd-wrt, but I don't see the point. Perhaps you can elaborate on your use case?

  • Thanks for your response, understood everything you have said there. The reason I wanted the WRT3200ACS to have access is that I want it to download some packages for monitoring. As it can't resolve DNS these fail. The ISPs modem is the only DHCP/DNS server on the network. The WRT3200ACS is taking it's lease from that server and getting an IP. No idea why it won't also take the DNS setting and you dont seem to be able to override this from the dd-wrt frontend. – Jeff LeCoat Feb 21 at 11:03
  • Interesting. If DNS isn't automatically transferring from the lease to the router's DNS table, then you are generally safe copying it over manually. DNS server IPs tend not to change. You can also put in Google Public DNS A (8.8.8.8) or something else from this list: en.wikipedia.org/wiki/Public_recursive_name_server – Andy Feb 21 at 19:51
  • Thanks again for replying Andy. End result of this was I gave up on dd-wrt. Did some speed tests and the stock firmware is much faster. Can't even be bothered now to debug it as it's such a pain to work with. dd-wrt doesn't have the hardware comparability or stability in it's current state. I'm reasonably competent with networking and working in a unix shell, and it's been a complete ball ache to get it even partially working. dd-wrt is very much not recommended unless you really know what you're doing and that the hardware is old and confirmed as supported. – Jeff LeCoat Feb 23 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.