I have Nvidia graphics card installed and the Ubuntu used to work without any issue till yesterday. Unfortunately, it is now stuck at the login screen. I switched to terminal mode (Ctrl+Alt+F1) and removed Nvidia drivers using the following command:

sudo apt-get purge nvidia-*

It works! However, I want to use Nvidia drivers so after logging in successfully, I installed Nvidia drives from "additional drivers" under "software and updates" in Ubuntu. After rebooting, it again stuck at login screen.

Below is the permission info. for .Xauthority file:

ravi@lab:~$ ls -la .X*
-rw------- 1 ravi ravi 48 Feb 20 11:43 .Xauthority
-rw------- 1 ravi ravi 48 Feb 20 11:27 .Xauthority.bak

I am not able to figure out the cause of the problem. Below is the content of dmesg:

[    1.342426] init: plymouth-upstart-bridge main process ended, respawning
[    1.544607] Adding 16734204k swap on /dev/sda3.  Priority:-1 extents:1 across:16734204k SSFS
[    1.594473] systemd-udevd[359]: starting version 204
[    1.596107] tsc: Refined TSC clocksource calibration: 3600.032 MHz
[    1.620273] lp: driver loaded but no devices found
[    1.631667] ppdev: user-space parallel port driver
[    1.649728] wmi: Mapper loaded
[    1.651556] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[    1.681165] [drm] Initialized drm 1.1.0 20060810
[    1.690956] type=1400 audit(1550630628.420:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=487 comm="apparmor_parser"
[    1.690962] type=1400 audit(1550630628.420:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=487 comm="apparmor_parser"
[    1.690965] type=1400 audit(1550630628.420:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=487 comm="apparmor_parser"
[    1.691995] type=1400 audit(1550630628.420:5): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/sbin/dhclient" pid=493 comm="apparmor_parser"
[    1.691999] type=1400 audit(1550630628.420:6): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=493 comm="apparmor_parser"
[    1.692002] type=1400 audit(1550630628.420:7): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=493 comm="apparmor_parser"
[    1.693989] snd_hda_intel 0000:00:1f.3: irq 182 for MSI/MSI-X
[    1.768260] checking generic (d1000000 7f0000) vs hw (c0000000 10000000)
[    1.768261] checking generic (d1000000 7f0000) vs hw (d0000000 2000000)
[    1.768262] fb: conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver
[    1.768280] Console: switching to colour dummy device 80x25
[    1.768906] nouveau E[  DEVICE][0000:01:00.0] unknown chipset, 0x134000a1
[    1.768910] nouveau E[     DRM] failed to create 0x80000080, -22
[    1.769175] nouveau: probe of 0000:01:00.0 failed with error -22
[    2.019597] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro
[    2.229627] init: failsafe main process (750) killed by TERM signal
[    2.415213] Bluetooth: Core ver 2.17
[    2.415250] NET: Registered protocol family 31
[    2.415251] Bluetooth: HCI device and connection manager initialized
[    2.415255] Bluetooth: HCI socket layer initialized
[    2.415257] Bluetooth: L2CAP socket layer initialized
[    2.415259] Bluetooth: SCO socket layer initialized
[    2.418438] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    2.418447] Bluetooth: BNEP filters: protocol multicast
[    2.418451] Bluetooth: BNEP socket layer initialized
[    2.425587] Bluetooth: RFCOMM TTY layer initialized
[    2.425608] Bluetooth: RFCOMM socket layer initialized
[    2.425634] Bluetooth: RFCOMM ver 1.11
[    2.446701] type=1400 audit(1550630629.176:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=837 comm="apparmor_parser"
[    2.446704] type=1400 audit(1550630629.176:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=837 comm="apparmor_parser"
[    2.465787] init: cups main process (842) killed by HUP signal
[    2.465817] init: cups main process ended, respawning
[    2.497078] type=1400 audit(1550630629.224:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=916 comm="apparmor_parser"
[    2.558491] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    2.588489] init: alsa-restore main process (1031) terminated with status 19
[    2.598291] Switched to clocksource tsc

Any workaround, please? I guess that some Nvidia configuration files need to be cleaned properly.


The problem is

[    1.768906] nouveau E[  DEVICE][0000:01:00.0] unknown chipset, 0x134000a1
[    1.768910] nouveau E[     DRM] failed to create 0x80000080, -22
[    1.769175] nouveau: probe of 0000:01:00.0 failed with error -22

The graphics card that you have is not supported by the nouveau drivers. That is probably why you had installed the NVIDIA propriety drivers in the first place.

You can either re-install the NVIDIA drivers and disable the nouveau driver (be sure to blacklist nouveau!) or downscale to VGA-like drivers.

To blacklist the noveau drivers, insert

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

into /etc/modprobe.d/blacklist.conf and reboot, before installing the NVidia driver.

(the last part is quoted from https://askubuntu.com/questions/481414/install-nvidia-driver-instead-of-nouveau which I found with google, and I have not tried it).

| improve this answer | |
  • Thank you very much for this wonderful explanation. I have NVIDIA GeForce GTX 1050. I tried sudo apt-get purge nvidia-* to remove NVIDIA drivers and installed NVIDIA drivers from "additional drivers" under "software and updates" in Ubuntu. I also have CUDA 8.0 working. Is there a better way to re-install the NVIDIA drivers ? Can you please explain how to disable and blacklist the nouveau driver? – Ravi Joshi Feb 20 '19 at 12:18
  • Thanks again for the help. I removed NVIDIA and then installed again from "additional drivers" under "software and updates". As per your suggestion, I have also blacklisted the noveau drivers. Later from CLI (Ctrl+Alt+F1), I executed sudo update-initramfs -u. However, the problem persists. I am sharing the blacklist.conf and dmesg with you. Please have a look. – Ravi Joshi Feb 21 '19 at 6:14
  • I just want to add this> I installed nvidia-410 from ppa:graphics-drivers/ppa -y but the problem persists. I am sharing the new dmesg file. Please have a look. – Ravi Joshi Feb 23 '19 at 3:45

It seems that the package shim-signed was the culprit. Hence after removing it, I reinstalled NVIDIA. We need to restart the PC and it works

sudo apt-get remove shim-signed
sudo apt-get install nvidia-384

The secure boot was disabled in my PC from the BIOS menu. Please note that the answer is originally posted here.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.