0

I use trello.com for a bunch of stuff, and they use a CDN to deliver their assets. One of my computers is having trouble getting access to these assets, and I'm having trouble identifying where the issue is. Here are the steps I've taken so far:

  • I tried loading the site on my other computer on the same Wifi, and it worked fine.
  • I tried loading the site in different browsers (Chrome, IE, Firefox), and they all ran into the same issue.
  • I disabled my firewall.
  • I cleared my browser cache.
  • I cleared my DNS cache.
  • I added the CDN to my list of trusted sites in my computer's proxy settings, though it forced me to add "https://" before the addresses listed in the Trello help page.
  • I added the CDN to the list of exceptions in my antivirus (Bitdefender)
  • I tried opening the page in an Incognito tab
  • I restarted my computer

The specific error in the browser console is:

Failed to load resource: net::ERR_CERT_COMMON_NAME_INVALID

It says that dozens of times, once for each failed asset on the page.

I followed all the instructions on their troubleshooting page here: https://help.trello.com/article/771-loading-resources-from-trellos-cdn

Both computers that I tested are Windows 10.

Any other suggestions?

2
  • Since the error complains about the certificate, can you provide details on the certificate, and specify if you have any security software that is scanning your HTTPS traffic. If you do (disable it) immediately and try again. Any helpful information who be added to the question instead of a comment
    – Ramhound
    Feb 21 '19 at 4:46
  • 1
    If you trust the certificate, you could always put it in your certificate store, that should either make chrome trust the certificate or give you a different certificate error
    – Ramhound
    Feb 21 '19 at 4:56
1

It was Bitdefender. Adding the CDN to the list of exclusions didn't work. I had to actually turn off the protection shield. I'll be taking this up with their support.

Note: as suggested by Ramhound in the comments, I also tried adding the certificate to my certificate store. That's actually how I figured out it was Bitdefender. The root certificate was listed as Bitdefender. Added that certificate to the store didn't work, but thankfully I knew then that I just had to temporarily disable Bitdefender.

2
  • I would just disable BitDefender from being able to scan secure HTTP traffic. It breaks the internet, BitDefender could virtually do anything it wants, when it scans what otherwise would be encrypted traffic
    – Ramhound
    Feb 21 '19 at 6:11
  • 1
    Well, it can already do anything it wants, when it's an antivirus program running on your computer...
    – user1686
    Feb 21 '19 at 8:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.