0

My Windows 10 machine sometimes denies me access to folders. (Screenshot below.) I don't understand why because according to Properties > Security I have "full control."

I tried clicking "Edit" as indicated, and also "Advanced." I also tried Properties > Read-only (uncheck & apply to contents). No matter what settings I apply, the folder remains denied.

How can I make it so I use the folder normally?

Is there a command I can run as Administrator that will fix the folder?

enter image description here

I tried running this tool on Microsoft's support site. It reported that it found and fixed problems, but had no apparent effect.

0

Assume your folder path is C:\Folder. To allow all permissions for current user, run these commands as administrator:

Takeown /F "C:\Folder" /R /D Y 
Icacls "C:\Folder" /grant %USERNAME%:(OI)(CI)F /T 

To allow only read and write permission, run these commands as administrator:

Takeown /F "C:\Folder" /R /D Y 
Icacls "C:\Folder" /grant %USERNAME%:(RD,WD,AD) /T 

To get further information read takeown and icacls command details from Microsoft Docs.

2
  • Thanks. takeown returned "SUCCESS" messages for everything in the dir, but icalcs errored out "Access is denied". I checked the docs you linked & tried running it with /c (among many other things). When I did that it returned a separate "Access is denied" for each subdir. How is it possible to be denied access if I'm logged in as Administrator? Is there a level of authority greater than Admin in Windows? Any other things I could try?
    – Nafine
    Feb 22 '19 at 14:46
  • @Nafine Do not log in as administrator. Log in as a normal user. Try to replace %USERNAME% with Everyone (if you want) for both pair. Then run with %USERNAME%.
    – Biswapriyo
    Feb 22 '19 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.