4

Windows Explorer will not auto-refresh and show a new folder that is created (until Ctrl-R is pressed), nor will it remove a file from view that is deleted (until Ctrl-R is pressed).

How can I get Windows Explorer to begin auto-refreshing again?

I would also notice other programs that opened or created files to hang during creation/opening.

5

I attempted the registry key fix:

Navigate to HKEY_CLASSES_ROOT\CLSID\{BDEADE7F-C265-11D0-BCED-00A0C90AB50F}\Instance (HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{BDEADE7F-C265-11D0-BCED-00A0C90AB50F}\Instance for 64-bit systems) and create a DWORD (for 32-bit systems) or QWORD (64-bit systems) labeled dontrefresh with a value of 0.

...and while it may work for some people, it did not work for me.

I tried the following:

  • In Windows Explorer: choose Tools, Folder Options > Click the Search tab

    Check or uncheck ANY option

  • Apply.

  • If this solves your problem, you can revert to your original setting and the problem will remain solved.

...and while it may work for some people, it did not work for me.

I ran dism /online /cleanup-image /restorehealth&sfc /scannow&pause in an administrator Command Prompt and it found no issues (though it may work for you).

Solving my issue:

I found that a Samba file share that I had pinned to Quick Access was causing my issue. When the Samba file share was not present, Windows Explorer would freak out. After deleting the file share from my pinned Quick Access, the problem disappeared.

| improve this answer | |
  • 2
    This was my problem, too. It wasn't a Samba folder but a network share that is only accessible when I'm connected to my corporate VPN. I deleted that share and things started working normally again. – Tommy Williams Sep 17 '19 at 4:07
4

Try This: 1. Right click on desktop. 2. Select personalize 3. Click on themes 4. Scroll down and click on desktop icon settings 5. Click restore default 6. Click ok

| improve this answer | |
  • 1
    This worked for me in July 2020 when no other fix would. – Jerry W Jackson Jul 18 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.