2

A lot of parameters append to the searches we do on the address bar, here's a full list: https://moz.com/blog/the-ultimate-guide-to-the-google-search-parameters

I bookmark my Google searches a lot, and by a lot I mean I have more than 4 thousand of them. So I want the URL's to look tidy to identify duplicates better. The bookmarks are vocabulary look ups, like "Define word" etc.

Here's the search engines chrome://settings/searchEngines:

enter image description here

But I can't edit the query URL on the Google search engine:

enter image description here

And I can't make a new Google.com search engine probably because it would be a duplicate of the default Google search engine (the default google search engine can't be removed):

enter image description here


Seems like the question is vague? here's a better example:

When I search on the address bar which uses the default search engine which is google, I want my URL to look like this:

https://www.google.com/search?q=Define+Word

Instead of this:

https://www.google.com/search?q=Define+Word&oq=Define+Word&aqs=chrome..69i57j69i60l3j69i61l2.617j0j7&sourceid=chrome&ie=UTF-8
  • What is the question? – Bogdan Doicin Feb 23 at 11:44
  • What exactly are you trying to do? – harrymc Feb 23 at 12:07
  • Updated the question to make it more understandable – Shayan Feb 23 at 12:29
  • 1
    Instead of the actual search term, use %s in place of the search terms, when defining a "new" search engine. I believe your method should only work when attempting external queries. – joat Feb 23 at 13:01
1

You are unable to change the active and default search plugin. Steps should be:

  1. Change default from Google to another search engine (e.g. Bing).
  2. Edit Google.
  3. Change back the default to Google from Bing.

Alternatively:

  1. Create a new search engine - and name it something else e.g. Goog
  2. Change the default from Google to Goog.
  • 1
    Thanks! so I deleted the default and created a new one and in the query URL I added https://www.google.com/search?q=%s works nice :D – Shayan Feb 23 at 13:33
  • woops! shouldn't have deleted it! now the search prediction doesn't work! xD fixed it by restoring settings, and instead of deleting went exactly with your alternative option :D – Shayan Feb 24 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.