0

I had hard drive which was target location for CCTV, connected to linux mini pc running rsync in background to collect footage from few locations.

Well, I noticed that sometimes rsync failed due permission error and drive got unmounted by system, it happen few times but after reboot it was working fine, I decided to copy it to new drive, when I started copying on new - it seems it died. It didn't even had 1 full year of work time, around 7 months only.

Not seen in fdisk, not seen in df.

[  166.630651] usb 1-1.3: new high-speed USB device number 5 using dwc_otg
[  166.764048] usb 1-1.3: New USB device found, idVendor=0bc2, idProduct=ab44
[  166.764067] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  166.764078] usb 1-1.3: Product: Backup+ Hub
[  166.764088] usb 1-1.3: Manufacturer: Seagate
[  166.764098] usb 1-1.3: SerialNumber: 01CB7506B0MC
[  166.767450] hub 1-1.3:1.0: USB hub found
[  166.768127] hub 1-1.3:1.0: 3 ports detected
[  167.080564] usb 1-1.3.1: new high-speed USB device number 6 using dwc_otg
[  167.212743] usb 1-1.3.1: New USB device found, idVendor=0bc2, idProduct=ab38
[  167.212755] usb 1-1.3.1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  167.212762] usb 1-1.3.1: Product: Backup+ Hub BK
[  167.212769] usb 1-1.3.1: Manufacturer: Seagate
[  167.212776] usb 1-1.3.1: SerialNumber: 01CB7506B0MC
[  167.214136] usb-storage 1-1.3.1:1.0: USB Mass Storage device detected
[  167.215125] scsi host0: usb-storage 1-1.3.1:1.0
[  168.251708] scsi 0:0:0:0: Direct-Access     Seagate  Backup+ Hub BK   D781 PQ: 0 ANSI: 6
[  168.255463] sd 0:0:0:0: [sda] Spinning up disk...
[  168.266405] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  168.351029] usb 1-1.3-port2: Cannot enable. Maybe the USB cable is bad?
[  224.411031] ready
[  224.411442] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[  224.411842] sd 0:0:0:0: [sda] 15628053167 512-byte logical blocks: (8.00 TB/7.28 TiB)
[  255.340667] usb 1-1.3.1: reset high-speed USB device number 6 using dwc_otg
[  260.510807] usb 1-1.3.1: device descriptor read/64, error -110

Cable is okay, I tried replacing it. I did even tear plastic cover aparat, I did checked SATA connections, I tried connecting it directly in PC on Windows - disk didn't show up in disk manager interface either. Disk is bit vibrating, but it wasn't the quite one from beginning. Now when connected, after some time it makes weird short "ding,ding,ding" sound and stops, then again vibrating.

Can someone advise whether data is lost or is there any chance ? I'm not sure how to interpret the error from dmseg. I never had disk "die" in this way, I'd also appreciate someone explaining what actually might have happened.

I hope this is correct sub StackExchange.

migrated from security.stackexchange.com Feb 23 at 22:22

This question came from our site for information security professionals.

1

TL;DR recovery chances are probably good IF you seek professional help.

"after some time it makes weird short "ding,ding,ding" sound and stops, then again vibrating" - that is called the 'beep of death' and is usually caused by the actuator arm that's gotten stuck. More rarely, it's the platter spindle that got stuck, but in that case you should feel no vibration at all, just maybe a weak buzzing.

A stuck actuator arm means that the heads are safely parked and the data is all still there. If you could unstick the arm or replace it, you could get everything back.

It is remotely possible that you can fix it yourself: for mild stiction cases, just holding the hard drive in your hand, rotating the wrist so that the arm experiences a modest centrifugal force, may be enough. Others have had success by smartly rapping once on the case, on the smallest face perpendicular to the spindle, from the platter end towards the connector end. A smart rap will detach the actuator arms without making it crash against the platters.

Yet, chances are that this will wreck the disk more thoroughly, and the wise thing to do is to hire a professional. With a "white room" setup and the appropriate equipment, the hard disk may be opened, repaired and resealed, and finally backed up, in very little time.

  • I will try suggested steps, when it comes to disassembling - I suppose the most clean and sterile room with least dust is best environment to do that? Thank you for explaining everything with details. I will for sure update here with results. – user3370412 Feb 23 at 0:08
  • I tried all mentioned steps before actually opening it, they didn't worked. I opened and it turns out that actuator arm was actually locking in the middle, when I forced it through entire work area, closed disk. I hear it works now, however disk after reaching operating rpm, beeps once and shuts down. I suppose this is time to say goodbye or there is something I can try ? Professional help is not needed, I don't care about that data that much. – user3370412 Feb 23 at 0:38
  • 1
    No, I'm afraid that opening a disk in a normal room isn't survivable for a modern disk, nor is moving the arm over the platters. The single beep is probably the disk realizing the reading heads are either crashed or miscalibrated (the data is still probably recoverable but now requires even more effort - almost surely not worth it). – LSerni Feb 23 at 0:58
  • I tried everything else before. Someone else also suggested freezing hard drive, I also tried that, it was never worth spending money to fix it. It's just surprising to me that new expensive disk can completely fail so soon, I remember that old hard drives could have survived very very long and they degraded gradually having a lot time to actually back it up. Why does it happen now more often as I hear? – user3370412 Feb 23 at 14:47
  • @user3370412 modern hard disks have much less matter per bit. We are nearing the level where ambient radioactivity can induce (recoverable) bit failure, and mechanical tolerances are so small that a single grain of dust could cause catastrophic failure. I know that some disks are not rated for operation above a certain height because they can't tolerate the reduced head lift caused by the thinner atmosphere. – LSerni Feb 23 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy