1

I am using Word 2007 on a computer with Windows 7 Enterprise SP1 Korean version, but the Windows interface has been changed to English (User interface is completely in English, including all menu items, and installed programs detect system language as English). Text services and Input languages have been installed, and I can use it to switch between Korean and English using the 한/영 key

I am having a problem in Word (and I am supposing it happens in other Office programs like Excel or Powerpoint, but I haven't tested it) where typing seemingly random English letter combinations gets converted to their Korean equivalent. For example, typing a word (a variable name, for example) that contains a sequence cpe followed by a symbol (., space, etc) automatically converts cpe into 첻 (this is what you would have got if the keyboard was in Korean mode and you typed in the keys c, p and e in sequence). I have autocorrect set to it's default settings, normal correction of typos while typing in English works as expected.

How do I prevent Word from automatically changing English character sequences to Korean? I am not really sure what exactly triggers this conversion as I feel it is happening randomly (though I am pretty certain typing certain letter sequences followed by a space or . usually causes this to happen). Is there a way to disable this "inter language autocorrect" feature? I still need to be able to switch between English and Korean input when I want to do it manually.

-1

Try to clear the Detect language automatically check box. Maybe that will help you

  • 2
    Where would that checkbox typically be found? – music2myear Feb 27 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.