I completely failed at getting sound to come out of my Ubuntu 18 computer from the motherboard, from an internal sound card or from a USB sound adapter. Zero sound from any of those. What finally worked was to get a device that took an HDMI cable as input and converted it into an audio signal on a regular audio cable. This is a 2 monitor setup, so HDMI-0 is my main display and HDMI-1 is my secondary display. There is no third display, but the third HDMI cable, associated with HDMI-2, is used only for sound, so I don't want it to display at all.

This stopped working after a software update yesterday, which included lots of NVIDIA software. Now HDMI-2 is displayed along with the other two, as if it were a 52" monitor, which pushes the other two displays around so that they are mostly unusable. But when I turn off HDMI-2, while it fixes the other two displays, the sound from HDMI-2 stops working. So I'm back to a silent computer.

This is the xrandr command that worked before the software update:

xrandr --output HDMI-0 --scale 1x1 --mode 2560x1440 \
  --pos 0x0 --panning 2560x1440+0+0 \
       --output HDMI-1 --scale .6666x.6666 --mode 3840x2160 \
  --pos 2560x0 --panning 2560x1440+2560+0 

I've tried to add an additional output line for HDMI-2, such as

--output HDMI-2 --scale 0x0

...but nothing I've tried works, or is even accepted as a valid command by xrandr. Is there any way (hopefully via xrandr, but any other way that might help) to hide the display but not silence the sound?


You must log in to answer this question.

Browse other questions tagged .