I have just installed Visual Studio but it seems to have not installed properly. Here is a picture of the problem:


As you can see, there is no icon for the solution file even though Windows recognizes it correctly as a Visual Studio solution and opens it correctly.

How can I fix this?


Have you tried logging off or restarting? Did you make sure to install SP1 for Visual Studio 2008?

I had this problem once in XP and restarting fixed it. I run both Visual Studio 2008 and 2010 in Windows 7 x64 without any issue.

  • 1
    I did try restarting. After installing some Windows Updates (and them restarting me again), it's decided to work properly. Thanks!
    – James
    May 14 '10 at 7:20

I actually ran into this on Win7 x64 (using VS2008 SP1), and the problem turned out to be a botched install. Running the repair install from the Programs and Features control panel seems to start and repair partially before the installer crashes, but it still fixed the missing icons (just choose "cancel" after the "Did this program install correctly?" dialog). This also had the side-effect of fixing just-in-time debugging (which was also broken for our install).

I wonder how common this scenario is, since it looks like our image/deployment was made with this bad installation, but it's another thing that seems worth trying should others encounter this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy