1

I have:

  • Microsoft Office Home and Business 2013 English on
  • Windows 10 Professional English,

but I am editing texts in Polish.

I have permanently changed Footnote Text-style's language to Polish, but this is ignored and "reset" to English (United Kingdom) each time I add a new footnote:

enter image description here

Each time I add a new footnotes, I need to go to style settings and close this dialog with OK (changing Footnote Text-style's language to Polish again is not necessary; Polish is correctly checked when this dialog is opened, as you can see on above screenshot).

Or I have to manually change language of this line (for each new footnote).

Even more weird thing is that right after writing a new footnote:

  • when I select single word or nothing (only place cursor in footnote's line) -- status bar claims that the language of this line is set to English (United Kingdom) (as in screenshot),
  • when I select entire footnote's line (i.e. left-click on the left margin) -- status bar claims that the language of the very same line is set to Polish,

and then there and back again: Polish (when whole line is selected) or English (United Kingdom) (when part of it or nothing is selected).

Is this something known -- some bug or weird feature? Is there any workaround for this?

This problem occurs (in my case) for the Footnote Text-style's language only. Changes to all other styles and style's properties are permanent and I don't have to change anything manually.

Edit: The style is already defined and has language set to Polish. This is the first thing that I did. Yet, language in style definition is always ignored and it is reset to English (United Kingdom) when each new footnote is added.

1

The best approach is to change the style definition for footer that is used in the document. This is a better approach because any text that uses that style is affected immediately (excepting footers whose style you have already modified):

  1. Display the Home tab of the ribbon.
  2. Click the small icon at the bottom-right of the Styles group. Word displays the Styles task pane.
  3. In the list of styles shown, hover the mouse pointer over the name of the style you want to alter, which here is Footer and/or Footnote Text. A drop-down arrow should appear at the right side of the style name.
  4. Click the drop-down arrow and choose Modify. Word displays the Modify Style dialog box.
  5. Click on Format and select Language from the pull-down list. Word displays the Language dialog box.
  6. Select the language you want used by any text formatted with that style.
  7. Click on OK.
  8. Click on OK to close the Modify Style dialog box.

After more research I found out that the above advice works, but there is a bug in Word that nullifies it : When inserting the footnote via the ribbon, Word appends a single space character to the footnote that does not have the correct style as regarding the language.

The remedy is to start each footnote with a Backspace, which will delete this character and leave only the text that is in the right Footnote Text style.

Sources:

Note that the last source was created on October 2011. That's when the bug was reported to Microsoft, but was never resolved during the last 8 years.

| improve this answer | |
  • As you see in my screenshot, the style is already defined and has language set to Polish. Sorry for not mentioning that in my question (edited). This is the first thing that I did. Yet, language in style definition is always ignored and it is reset to English (United Kingdom) when each new footnote is added. You're saying about Footer style, I am using Footnote Text style instead, because that was revealed when using Styles Inspector on my footnotes. Anyway, both styles has language set to Polish. So your solution unfortunately doesn't bring anything new to the case, sorry. – trejder Feb 28 '19 at 16:19
  • Have you for these two styles unchecked the "Automatically Update" check-box at the bottom of the Modify Style dialog? – harrymc Feb 28 '19 at 16:34
  • No, I didn't (personally), but it seems both have this setting turned off by default. – trejder Mar 1 '19 at 13:32
  • I found out out that this is just a vulgar bug by Microsoft. See my addition above. – harrymc Mar 1 '19 at 14:24
  • Thank you. This now qualifies as an answer, so I was happy to upvote and accept it. Just a small tip on my side -- consider removing the first part about changing styles, since we both agreed that this is a bug, not a settings-related problem. – trejder Mar 6 '19 at 17:10
1

In terms of a workaround, I coded the following macros (had the same issue with UK and US English and German; macros inspired by harrymc's answer and the sources referred to). TGR

Sub InsertFootnoteNow()

' Intercepts built-in command

' Stand-alone macro is used (as opposed to built-in command) because footnote proofing language _
    cannot be permanently assigned to footnote text via style formatting but will switch back to system language settings. _
    Macro provides for work-around insofar as (1) the system language settings pertain to a single space character _
    Word appends to the footnote reference in the footer which is (2) deleted by this macro.

    If Selection.StoryType <> wdMainTextStory Then
        MsgBox "Footnotes can only be added to the main text body of the document." ' Preventing VBA/macro error if macro is triggered while selection/cursor is in footnote text 
    Else
        With Selection
            With .FootnoteOptions
                    .Location = wdBottomOfPage
                    .NumberingRule = wdRestartContinuous
                    .StartingNumber = 1
                    .NumberStyle = wdNoteNumberStyleArabic
                    .LayoutColumns = 0
            End With
            .Footnotes.Add Range:=Selection.Range, Reference:=""
        End With
        Selection.TypeBackspace
        Selection.TypeText Text:=vbTab ' Tab added to ensure justified alignment for my footnote text style paragraph settings
    End If

End Sub

Sub InsertFootnote()

    ' Intercepts built-in command prompting insert footnote dialog

    Call InsertFootnoteNow

End Sub
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.