1

A while back I upgraded my SSD capacity. I cloned the smaller 512 GB to the 1 TB to maintain all my files and not have to reinstall Windows and all that. (I used easeUS partition master or something similar)

In the process, the clone from one storage drive to another also copied the smaller "system recovery" local disks. Essentially those smaller size, < 1 GB, initially-hidden Windows drives.

Now those drives are visible to me and I'd prefer to have them hidden as they were originally.

It seems these drives are only listed in file explorer and not like in a dropdown menu when picking a list of drives/USBs with pendrive, bootable Linux installer.

But it still a little annoying seeing these drives on file explorer. So I was wondering if you guys have a solution for this.

(drive E, G, and H are the original configured to be the hidden ones when Windows was first installed)

enter image description here

3
-1

How I got the infoUse the recovery media for your PC in Admin mode or the CMD as an Admin.

When it opens the window - {Note- make sure you put the spaces in, for examples: DISK PART or SELVOL0 would be wrong as it does or does not have the spaces, respectively.

type "DISKPART" & hit enter then type "SEL DISK 0" & hit enter then type LIST VOL & hit enter

look at the list that then shows on the screen & pick out the ones that are the VOLUMES you want hidden, TAKE NOTE OF THE VOLUME NUMBER

then type SEL VOL X (X being the number of the volume you want to hide) & hit enter then type ATTRIBUTES VOLUME HIDDEN & hit enter

Do this for each volume you want to be hidden

then type EXIT & hit enter (you do this twice, once to exit the diskpart commands & the second time to exit the Admin command program.

I believe that when you restart your PC those volumes/partitions will then not be seen or visible (unless someone follows the same list above but at the last DISKPART command they type ATTRIBUTES VOLUME UNHIDDEN - instead of HIDDEN, using UNHIDDEN will make the volume/partition visible again). tHE PICTURE SHOWS THE INFO NEEDED FROM THE aDMIN COMMAND WINDOW except for the final two EXIT commands. I hope this helps.Admin Command Info & syntax

2
  • I'm not sure why someone downvoted you but this was the same solution from the duplicate question in the comments and it was the solution I used. Thank you
    – Cit5
    Mar 17 '19 at 1:49
  • There are always 3 or more ways to do the same thing in any Windows OS, just as there are multiple ways to explain anything. It doesn't matter to me if someone downvotes me, as long as it helped you I'm happy. It is shameful the way Microsoft Support websites close so many threads, SPECIALLY when people are still having the same problems.
    – A G S
    Jul 31 '19 at 17:21
0

It sounds like your partitioning tool might not have copied the metadata. OEM (Manufacturer) Reserved and EFI System partitions are not mounted by default in Windows, and the partition type is stored in the disk metadata (specifically, for GPT-formatted disks, in the GUID Partition Table).

I don't know off the top of my head what tool will fix this for you automatically, but you could do it manually with a hex editor if you boot a Linux liveCD or similar (obviously, this would be very risky, though).

You can also just un-mount the volumes in Windows. The Disk Management tool (use Start search or run diskmgmt.msc) allows you to remove drive letter assignments. You could also use mountvol.exe. Start CMD or Powershell as an Administrator, and run mountvol e: /p, mountvol g: /p, and mountvol h: /p to unmount the three drives and mark them to not auto-mount. You can use /d instead of /p if you just want to remove the automatically-assigned mount points.

0

Now those drives are visible to me and I'd prefer to have them hidden as they were originally.

It seems these drives are only listed in file explorer

But it still a little annoying seeing these drives on file explorer. So I was wondering if you guys have a solution for this.

It should be enough just to go to the disk manager and change the drive letter to none.

Would that do it for you, or am I missing something?

2
  • 1
    I wasn't able to change the driver letter to None. That option wasn't available on Windows or the driver partition program I was using. I ended up using the instructions in the previous question.
    – Cit5
    Mar 17 '19 at 1:47
  • This free partition tool always works for me when Widows disk manager doesn't. Give it a try Mar 17 '19 at 12:09
0

It's looks like you just want to hide the volume (the recovery volume). If you're familiar EaseUS partition master, using it to hide your volume. Here are the steps:

  • Right click on volume you want to hide
  • Click on Change drive letter (Change drive letter dialog appear)
  • Ensure New Drive Letter is selecting None and click Ok
  • Apply your change and check it in Explorer

Hope it helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.