I have a virtual machine on Azure, I let Azure install Ubuntuserver 18.04 LTS for me. After that I installed lxde and xrdp, and made inbound security rules in Azure for port 3389 and 22 with as the source using the ip address I am on right now. I have been able to connect via ssh and rdp from a windows 8.1 machine no problem up until this morning. I am running mozilla thunderbird on this machine only for testing.

When trying to connect trough either rdp or ssh the Azure vm is just unreachable. The only thing that 'fixes' the issue is to use the restart button on Azure, but this takes half a hour to complete restarting. After this restart it was working fine until I tried reconnecting again after 1 hour. Is it maybe the way I quit the rdp session? Or is it something else? I am fairly new to Azure so maybe it is something simple, but I can't seem to find the problem.

What I've tried:

  • Disable the 'DenyAllInBound' security rule.
  • Using the 'Identify and solve problems' feature on Azure
  • Checked if there is a malfunction on Europe west

If you face difficulties troubleshooting SSH or application access to a Linux virtual machine (VM) in Azure, redeploying the VM may help. When you redeploy a VM, it moves the VM to a new node within the Azure infrastructure and then powers it back on. All your configuration options and associated resources are retained. This article shows you how to redeploy a VM using Azure CLI or the Azure portal.


  • This seems to indeed fix the problem, however I still don't understand what caused it in the first place. – Rick Jelier Feb 28 '19 at 14:56
  • 1
    If you have support you can open a ticket b\c it's hard to know for sure. While we build redundancy into our cloud, hardware does fail. – Ken W MSFT Feb 28 '19 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.