2

There is an issue with displaying PDFs in Chrome PDF Viewer in the latest version of Google Chrome (72). If the PDF has Arabic and Hindi Font, it fails to load. The error received is "Failed to load PDF document". However, the PDF opens in Adobe Reader after download. Also, the PDF opens in other languages.Is there a way to disable Chrome PDF Viewer in versions 65 and above. Any help is greatly appreciated.

4

Is there a way to disable Chrome PDF Viewer in versions 65 and above?

If you’re using Google Chrome 68 or later versions in 2018 and want to disable Chrome’s built-in PDF Viewer to enable Adobe Reader or other desktop application for viewing PDF files on your computer, follow the instructions given below.

...

  1. Click on Chrome menu, select Settings

  2. Scroll down and click on Advanced

  3. Under Privacy & Security, click on Content Settings,

  4. Scroll down and click on PDF Documents or visit chrome://settings/content/pdfDocuments

    To disable Chrome PDF Viewer, turn on ‘Download PDF files instead of automatically opening them in Chrome’ Setting,

    To enable PDF Viewer, you need to turn off the above mentioned setting.

enter image description here

Source How to disable Chrome PDF Viewer [Updated for 2018]

-1

"Disable chrome PDF Viewer" is not possible in new chrome versions. But you can install chrome extension to view PDF in Adobe PDF viewer. So for this go to Chrome web store link and install Adobe PDF viewer. This might solve your problem. Now you have two options in Chrome browser to view PDF either in chrome PDF viewer or chrome Adobe PDF viewer

  • 1
    It still opens on Chrome, don't know what are you trying to say there. – CaldeiraG May 24 at 9:22
  • Install extensions from chrome store then you can view pdf using Adobe but not default chrome version. But disable chrome PDF viewer is not possible – rupali May 24 at 9:31
  • I see what you trying to say but DavidPostill solution works just fine on Chrome 74. – CaldeiraG May 24 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.