I went to


to check to see what my external IP address. Regardless of what port I enter, it tells me that the port is blocked.

I have a LinkSys router that basically has the default settings with the exception that I have WEP encrptin setup and I have forwarded a few ports, including 80 and 69. I forwarded them to the 192.x.x.103 IP address of the PC which is running IIS.

That PC runs Symantec Endpoint Protection, which I right mouse clicked in the tray to Disable.

These steps used to make my PC visible so I could host my own web site in IIS on port 80, or some other port, like 69. Yet, the Open Port tool cannot see my IP when it checks eiether port and when I navigate to http://my external ip/ I get "page cant be displayed"

At first I was thinking that maybe Comcast is blocking port 80, but 69 doesnt work eiether.

I do not see any other blockking set up in my router and, as I mentioned, I went with teh defaults except where discussed.

This is a corporate PC and Symantec End Point Protecion is new to it (this previously worked on teh same PC with Symantec Protection Agent), but I thought that disabling Sym End Pt from the tray, that that would effectively neutralize it. I do not have the rights to kill the program itself.

Any suggestions on what else to try to make my PC externally visible?

  • Try another port. 69 is well known as well, so they'll probably block that too. en.wikipedia.org/wiki/… Why don't you try port 55554 or something. Also, can you access the website on the local LAN? e.g. 192.x.x.103? – Nitrodist May 14 '10 at 8:26

Hard to tell if this is something better suited for Superuser.com but I'll give it a shot.

First, if you are going to forward ports you may want to use a static IP address and most likely not a wireless connection if at all possible, you don't often hear of a server running over a wireless connection. Have you made sure IIS is running and you can browse the site on "http://internalIP:portnum?" If that doesn't work you are not serving anything to begin with.

Second, have you checked the Windows Firewall? You did not mention the version of Windows being used but by default Vista and 7 both have the firewall enabled and those ports are blocked. If you turned off the Symantec firewall you may have overlooked the Windows firewall.

NOTE: You can also add a period after the IP address or machine name to force Windows to route over the local network TCP adapter instead of finding itself, this is good to check the firewall as sometimes internal requests for itself will not get blocked. Should look like this: ""

Thirdly, Comcast is evil. It is much more likely that they are blocking it all together. If none of the ideas above work you may want to try to find out if Comcast is blocking your access.

  • It's not a wireless connection. Adding a dot to the end of the IP address didn't change anything. I'm not running Windows firewall. I am running XP Professional. Comcast told me they ain't blocking it (and it used to work.) When I ping my owne external IP, I get no reply. Also, perhaps most importantly, when I type in http://(externalipaddressgoeshere) Get get a popup dialog that says "The server 24.xx.xx.xx at UTA200-TM requires a username and password. Is this my router asking me for my admin password? If so, I enter it correctly and it gives me an unauthorized error. – Chad May 15 '10 at 21:08

I reset my router to the factory settings and, as far as I can tell did the exact same thing and it worked. I think my router needs an occasional reboot. It must have been designed by MS


Residential Comcast service blocks port 80. You need a static IP and Comcast Business Service to run a web server normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.