5

I have been at it for about two days and let me give a detailed account of all the settings that I have set.

For the sake of clarity I will call the router which as Internet connection (WAN) as the mainRouter and the old router which I want to use as a repeater as the the secondRouter.

In the screenshots I have the SSID of the mainRouter as iball100 and that of the secondRouter as iballRep

Here are the settings for the mainRouter

Main router settings

And now for the Settings for the secondRouer

enter image description here

The problem that i have is that the secondRouter does not have access to the internet. When I connect to the secondRouter it says "connected,No internet". I have tried connecting to it using my phone as well still get the same thing.

The secondRouter doesn't show as a connected client on the mainRouter, is a thing that I observed.

I have no clue as to what am I missing here. The settings that I have work well for youtube videos which I saw, link here.

Any help in this regard will be appreciated.

4
  • 2
    What does it offer as system mode? – davidbaumann Mar 21 '19 at 15:34
  • I myself have been down this path. Doing this depends on the router. Does this router claim to support acting as a repeater/extender? Many routers will only take the internet from a wired port in the back. – Señor CMasMas Mar 21 '19 at 15:45
  • 2
    How are the two routers connected? What is your topology? – Fanatique Mar 21 '19 at 21:30
  • 1
    Whats the make/model & version numbers on the underside sticker? Both routers please. – Tim_Stewart Mar 21 '19 at 22:17
1

According to the manual for the second device: iB-WRX150NE, it does not have a repeater mode. It can act in Wireless Router mode or Wireless Client Router mode. The Wireless Client Router mode allows you to connect wired clients using this router as a bridge to the other wireless network. It cannot wirelessly provide access and also act as a bridge.

See section 4.5 Operation mode:

https://www.iball.co.in/File/Product/Drivers/iB-WRX150NE%20User%20Manual.pdf

1
  • The mode is not available as you said, but the WDS option is and that is what makes it communicate with other router. I got it working by switching the routers i.e, using the TPLINK C1200 as the secondRouter and using my old Iball router as the mainRouter. – krv Apr 17 '19 at 8:04
1

I tend to agree with my esteemed colleague #HackSlash, the device does not seem to support the feature... Yet, you might want to try a hack which I used with a cisco router a few years back:

  1. Back up your current settings - “System Tools → Backup & Restore”
  2. Connect the network cable (RJ45) from the mainRouter to one of the numbered LAN inputs (not the WAN!)
  3. Keep the same SSID name (change the channel to 4 - the difference between channels need be at least 3 slots)
  4. Change the operation mode from 'Router' to 'WISP' (Wireless Client)
  5. Save settings and restart the secondRouter

I cannot test it on your router model, so I cannot confirm it works... If the system behaves strange - restore from “System Tools → Backup & Restore” and restart.

0

While this router seems to be decent, I am thinking that it does not support this feature. If none of the suggested fixes work you can try flashing it with DD-WRT. I did not see the device as being supported on this site:

https://wiki.dd-wrt.com/wiki/index.php/Supported_Devices

The actual manufacturer of the device or the firmware may be different than the outside branding. I have done this many times and there are numerous posts on how to configure it. It may be a little much at first, but it becomes easy.

Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.