1

I just dual booted Linux Mint to my Acer Aspire F15. I already had windows 10. The installation of Linux went fine but whenever I restarted my computer it just went straight to windows 10 and didn't give me the option to boot in Linux.

So I checked on the internet for my problem and on this website (https://itsfoss.com/no-grub-windows-linux/) I came accross the following 'solution':

In windows command prompt, enter the following command:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

I didn't exactly know what this meant but I tried it anyway, but after I restarted my computer I got the following error:

Boot error

If you can't read it from the picture:

Failed to open \efi\boot\max64.efi
Failed to load image \efi\boot\max64.efi
Failed to start mokmanager: not found
Something has gone seriously wrong: import_mok_state() failed: not found

This error message shows up for about 10 seconds and then my computer just shuts down. I can't boot it in either windows or linux. I really hope I didn't delete my Windows 10, because I haven't backed up all my files. At this moment I don't really care about the Linux so just being able to start my computer in Windows 10 would solve my problem for now.

When I go to BIOS (the only thing I can access), windows boot manager is still one of my boot options. It is the first one in the priority order. The boot mode is set to UEFI and secure boot is enabled.

I really hope someone can help me.

1
  • 1
    If you run a Live Boot disc, you should be able to correct the boot record. The simplest way is to use boot-repair. If this isn't pre-installed on your Live Boot, you will need to down-load and install it each time you boot.
    – AFH
    Mar 2 '19 at 16:07
0

If you disable Secure Boot, you probably will see GRUB bootloader and would be able to boot Ubuntu at least.

By running bcdedit command you have replaced Windows boot entry with Ubuntu (I assume Linux Mint uses Ubuntu's bootloader and /ubuntu/ path) pre-bootloader (shim), which is designed to boot bootloader with Secure Boot mode enabled. For some reason, it's unable to find mmx64.efi—MokManager utility.

First, try to boot other boot options if you have them. If you have Ubuntu there, check if it boots. If it doesn't, the easiest way to repair your system is to run boot repair procedure from Windows installation disk. You can also repair your bootloader from Linux LiveUSB, with something like this:

sudo efibootmgr -c -d /dev/sda -p 2 -w -L Windows -l '\EFI\Microsoft\Boot\bootmgfw.efi'

Where /dev/sda is your HDD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.