Recently, I tried to download this zip file with Chrome v72.0.3626.121. Chrome simply deleted the file as soon as it downloaded it.

A mere message informed me that "Chrome has blocked jd-gui-windows-1.4.0.zip, because this file may be dangerous.". I did a quick search ending up on a Google support page.

This page explains why some downloads may be blocked. Among the proposed reasons, I spotted this one: "We think it might be a malicious, unwanted, or uncommon file."

So I sent this file to virustotal.com. You may check the detailed produced report. virustotal.com didn't find any problem with this file. On my side, I use the program in the zip regularly for years.

How can I disable this Chrome feature?

  • 1
    duckduckgo led to essentially the same fix (slightly different wording from an older version). And you're shunning google & haven't switched away from Chrome yet, at least to Chromium?
    – Xen2050
    Mar 2, 2019 at 18:56
  • @Xen2050 The computer I use Chrome is not mine.
    – Stephan
    Mar 2, 2019 at 19:02

2 Answers 2


Just a workaround per file...: Hit CTRL+J and per downloaded file you can indicate if you want to keep it anyway (or not..). I know that's a workaround, but it's at least more safe than turning off protection.

  • 1
    Sometimes you want things to work, not to be secure
    – Rainb
    Dec 14, 2020 at 18:59
  • That option wasn't available to me
    – KERR
    Mar 28, 2022 at 2:31
  • This is the best option I have found so far. I prefer keeping safe browsing on most of the time and I didn't realise that the downloads tab gave the option to keep the file. Jul 1 at 10:53

Solution #1

  1. Click on the "View Site Information" button on the left side of the URL (Padlock Icon) and click "Site Settings".
  2. Set Insecure Content to "Allow" and it will no longer block downloads from that site.

Solution #2

You can also whitelist entire websites via Chrome's settings:

  1. Settings > Security and Privacy > Site Settings > Insecure Content.
  2. Under Allowed to show insecure content click "Add" and enter the main website URL and click "Add".

Solution #3

Here is how I did:

  1. Go to chrome://settings or just click on the settings icon on the dashboard.
  2. Scroll to the bottom of the settings page and click on Show advanced settings
  3. Under advanced settings, find the subsection called Privacy and Security. Then look turn off the option Protect you and your device from dangerous sites.

=> You can now download anything from Internet AT YOUR OWN RISK !

=> You can turn back on the option.



  • 7
    While this works and possibly the only option this is totally braindead because the old dangerous sites protection was useful while this download blocker is totally hamfisted.
    – chx
    Apr 3, 2019 at 6:17
  • 1
    It seems that this option is no longer available, at least for the moment. On Windows, for me, there is no section called Privacy and Security under Advanced settings anymore, and the settings under the main Privacy and Security section offer no agency here. I set my Safe Browsing setting to "No Protection", but still, no luck. Mar 8, 2021 at 23:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .