I want to use an old laptop(Dell E5420) as a CentOS7 server in my home, so it is not required at all to operate it on the console, and certainly there is no X-server or other GUI on it.

When it is running, the screen(monitor) always emits some annoying light. I can not simply close the lid, because this will suspend the computer. To prevent it from suspending when the lid is closed, I configured the HandleLidSwitch option of the /etc/systemd/logind.conf to ="ignore". It works, that the system does not suspend when the lid is closed, but the back-light of the screen still is on, and very glaring especially at night.

It is not only annoying, but also consuming power and lifetime of the screen unnecessarily. I tried "setterm -blank 1 -powersave powerdown". If I issue this command on the console, it works, but does not if through a remote ssh terminal("setterm -blank 1 -powersave powerdown >> /dev/tty0" doesn't work also). If I issue the command through a pseudo terminal(ssh), the result is "

setterm: cannot (un)set powersave mode: Inappropriate ioctl for device


My ultimate purpose is put this command into a startup script or a systemd.service that will run once the system has started.

My question is : Is there a way in it I can turn off the backlight of the screen without logging-in the console of the laptop?

Btw, I tried to install vbetool but failed, maybe I should use another repo of yum?

Thanks a lot! Sorry for my English, I'm a Chinese.

  • try this: echo 0 | sudo tee /sys/class/backlight/intel_backlight/brightness – DDS Mar 4 '19 at 9:55

To set power saving on boot, you can put the commands in /etc/rc.local . Edit it manually, or:

echo 'setterm -blank 1 -powersave powerdown' >>/etc/rc.local

To prevent the "Inappropriate ioctl" message when running it via SSH, you also need to set stdin to the terminal you're trying to control:

setterm -blank 1 -powersave powerdown >/dev/tty0 </dev/tty0

PS your English is excellent, as good as most native English speakers. :)

  • Thanks for your help! But they all don't work. – Leon Nov 12 '19 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.