4

Since this morning, all alt codes I type in (like alt 256, alt 26, alt 144, ...), are replaced by the "�" character. It also happens sometimes in Windows with accentuated characters (like é à ï ...). I.E when I tried to uninstall/install some programs, I could have such issues from one prompt window to another :

examples

And funny enough: it's not 100% reproducible. If I try to get back the window from the screenshot, I might have it displaying correctly, or not. And some other displayed correctly before would display some � the next time. Kind of randomly.

No idea where this comes from. I'm not the owner of that computer, nor the only one using it (it's a school's computer). I have admin rights though. Any idea how to fix that?

3
  • See if this sheds any light: en.wikipedia.org/wiki/UTF-8
    – fixer1234
    Mar 4 '19 at 10:55
  • I know what UTF-8 is, thanks. It doesn't get me anywhere though.
    – L0Lock
    Mar 4 '19 at 17:01
  • UTF-8 uses that symbol for characters it can't represent. There's a section in the link about that. It's common with extended character sets used for accented and non-English characters, and certain characters in the lower 256. There's also a section on the Byte Order Mark. So seeing them isn't unusual. The unusual part is that 26 and 144 shouldn't produce it, and it shouldn't be random whether or not the same character appears as that symbol.
    – fixer1234
    Mar 4 '19 at 21:03
4

I found the solution by wondering around the system settings. x)

I'll explain the procedure here (my computer is in french but I'll translate, and you can rely on the icons too).

Requirements :

  • administrative rights
  • reboot at the end to apply the changes

  1. Open the Control Panel (for that you can type it in your start menu) : open control panel

  2. Go to Clock and Region clock & region

  3. Go to Region (in Windows 7, it might be Region and Language instead) region

  4. In the Administration pannel, hit the Change system locale button. admin panel - change system locale

  5. Uncheck the option « Beta: use Unicode UTF-8 for worldwide language support. » uncheck that beta thing

  6. Hit Ok, and restart as asked.

2
  • If this really fixed your issue, you can (and should) accept your answer as the correct one (the green tick below the vote up button).
    – Fanatique
    Mar 6 '19 at 9:37
  • Yes i know, it's just that the site obliges to wait 40min before being able to accept my own answer. x)
    – L0Lock
    Mar 6 '19 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.