0

Brand & model: Acer Aspire E 15 E5-575-33BM
Current OS: Windows Home
Motherboard: Acer Ironman_SK V1.25
Processor: Intel Core i3-7100U
Bios: Insyde Corp. V1.25

I downloaded this iso and I'm trying to follow these instructions.

This is the first screen shown: enter image description here

Then I'm running into two situations:

  1. it shows this error: enter image description here
  2. If I do nothing and let it continue it shows all the screens depicted in step 5 (legacy BIOS System) until the one with the instructions for creating the partition for Linux, only instead of showing 'free space' like in this picture enter image description here

it actually shows unusable partition (this is the disk space I created by shrinking C: in previous steps).

I don't know if I did it right but I tried disabling TPM but it didn't work. I also tried setting acpi=off, nolapic and nomodeset in this screen to no avail: enter image description here

I'm not a Linux expert, I would very much prefer to install Linux in BIOS/legacy mode since that's how I'm booting Windows right now, instead of reinstalling Windows to make it UEFI.

Thanks for the help

UPDATE:

Current partition state: enter image description here

7
  • Linux requires a disk to be partitioned in order for it to be installed. That being the case you'll want to make sure you make a separate partition in a compatible format for Ubuntu.
    – xpkiro
    Mar 4 '19 at 22:58
  • 1
    @JoshMcMullin - Not true: the Ubuntu installer can create partitions during the installation process. However I suspect the disc has been formatted as MBR, so there are no more partitions available. If /dev/sda3 is not needed (it seems too small to be relevant), it could be deleted, allowing a partition to be created in the 21GB free space.
    – AFH
    Mar 4 '19 at 23:05
  • @AFH; so you think it's because of the partition limit for MBR? so I should delete some of the partitions? AFAIK I can create up to four partitions on a basic disk using MBR: either four primary partitions, or three primary and one extended. BTW, the picture I posted is not my machine, it's the one in the tutorial. I updated the question with my current partition state. Finally, any thoughts on the first error screen? thanx Mar 5 '19 at 1:27
  • Is it possible that you have created 4 primary drives, and so do not have a spare primary so you can't create an extended and then logical partitions? Been a long time since I've done partitioning in Windows (as in, Win2k era)....
    – ivanivan
    Mar 5 '19 at 3:20
  • also gparted should be on the Ubuntu live disc, I'd recommend looking at things with that vs. the windows disk utility.
    – ivanivan
    Mar 5 '19 at 3:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.