0

My daughters's Dell Latitude e5250 is unable to charge through the DC jack. When the adapter is plugged in (standard Dell 65W charger), the laptop runs, but it will not charge the battery.

When I put the laptop into a docking station, the battery charges normally. This works with both the laptop's 65W adapter and the docking station's 130W adapter.

At this point I thought it might be the DC Jack itself, so I purchased a replacement. This made no difference - the battery would not charge with the new jack. The DC jack is complicated to replace on this laptop, but fortunately it can be unplugged from the bottom and the replacement can be tested without fully removing the original.

I also tried plugging the 130W adapter into the DC jack with no improvement.

At this point I am stuck. The battery can be charged, just not through the DC jack, only through the docking station. This is very inconvenient.

Any ideas?

  • Dell systems usually provide some warning during startup or diagnostic info in the BIOS about the battery and power adapter. Do you see any messages during a reboot? Have you checked in the BIOS for the battery status and for the power adapter status? The latitudes specifically have more advanced charging settings in the BIOS. – Appleoddity Mar 5 at 3:17
  • Yes, it comes up with a low wattage error when booting. It says the power adapter is plugged in, but not charging. There is no error when booting up while the laptop is plugged into the docking station. – Mike Thompson Mar 6 at 4:07
  • It sounds as if though it is unable to detect the power adapter. That is done via the center pin. If you tried a new jack and two different power adapters then the problem must be the motherboard. That is probably not worth repairing. It would be best to have it professionally evaluated. – Appleoddity Mar 7 at 2:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.