2

When I try to change the volume in cmus on MacOS using + or -, I see an error message:

Error: can't change volume: Operation not supported by device

This is annoying because, even though I can adjust the system volume incrementally with Option + Shift + Volume key, it's hard to get it low enough for some loud tracks.

How can I enable adjusting the volume in cmus itself?

3

Enable softvol

  • In cmus, press 7 to go to the setting screen
  • Either scroll down to the softvol setting, or press / to search for it and start typing softvol to jump right to it
  • Press enter. At the bottom of the screen, you'll see :set softvol=false
  • Edit that, changing the false to true, and press enter to save the setting
| improve this answer | |
  • 2
    Yes, I answered my own question in order to help others, and yes, that's allowed and encouraged on the site. Feel free to post an answer if you have an alternate solution. – Nathan Long Mar 7 '19 at 13:44
  • This is not a good solution. Softvol is not the real sound card volume, but an internal software volume, which means it probably degrades sound quality. That’s settings must be left the way it is. CMUS seems to have trouble accessing control devices. – retrography Jul 26 '19 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.